DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2010 Dodge Ram Forum


Notices

2010 Dodge Ram Forum For specific discussion of the new 2010 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 11-20-2013, 07:44 PM
saskplumber saskplumber is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: Saskatchewan
Posts: 10
Gender: Male
Vehicle: 2010 Dodge 1500
Trim Level: Laramie
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
saskplumber is on a distinguished road
Default FOB Remote Starter/Malfunction Indicator Light

Hey Guys.So here's my problem.I live in Southern Saskatchewan and if any of you know the part of the country,you know it can get dam cold here in the winter.I love my truck but I HATE the remote starter.When it dips down the Malfunction light always come on and stays on for periods of time.When it's on you can't use the remote starter and it drives me crazy.Should I have a sensor replaced?Can I get the MIL disabled somehow?Would the remote starter work with it disabled?

I was planning on putting in a aftermarket remote starter next week,but if this nonsense keeps happening,probably going to scrap that idea.

Thanks
Reply With Quote
Sponsored links
  #2  
Old 11-21-2013, 10:03 AM
Asur Asur is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Posts: 6,850
Gender: Male
Vehicle: .
Rep Power: 14
Rep:4371
Asur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond repute
Default

For about 80$ you can get yourself an Xpess kit DB-ALL, it will use your current remote, will install in like 15 min (plug and play), not cutting into any wiring uses a T-connector cable under your dash to your ignition key module, might be a way to go if you have to pay the dealer to look at your current remote start setup. Just a thought
Reply With Quote
  #3  
Old 11-21-2013, 11:57 AM
dbuzz77's Avatar
dbuzz77 dbuzz77 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2013
Location: Saskatchewan, Canada
Posts: 148
Gender: Male
Vehicle: 2009 Ram RCSB 4x4
Trim Level: Sport
Color: Stone White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 2
Rep:100
dbuzz77 will become famous soon enoughdbuzz77 will become famous soon enough
Default

do you mean that light with the lightning bolt? if it is that i think that is a communication error and should be looked at.
__________________
2009 RCSB Sport, SC Cortex, K&N air box, all Amsoil fluids, Fan delete, Grounded TB, homemade catch can, homemade gps mount, Fastman TB, EZ down tailgate, Bully hitch step
Then God made a hemi, and knew that it was good.
Reply With Quote
  #4  
Old 01-05-2014, 04:58 PM
saskplumber saskplumber is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: Saskatchewan
Posts: 10
Gender: Male
Vehicle: 2010 Dodge 1500
Trim Level: Laramie
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
saskplumber is on a distinguished road
Default

I think I have a bad Oxygen sensor.The MIL will come on and the eco will not work.This has been ongoing for too long.Gonna contact the shop in the morning and ask they replace it.The truck has always ran great but this is a pain in my .So if the MIL goes away does the truck store the error code from the problem?

Thanks
J
Reply With Quote
  #5  
Old 01-10-2014, 08:23 AM
saskplumber saskplumber is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: Saskatchewan
Posts: 10
Gender: Male
Vehicle: 2010 Dodge 1500
Trim Level: Laramie
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
saskplumber is on a distinguished road
Default

Well that was a big waste of time.Took the truck in and they told me the MIL/error was due to engine misfire and that there were codes for these misfires but they had already applied the code updates to my vehicle sometime ago.They said my O2 sensor was fine.They quoted me approx 780$ to replace all the O2 sensors.F-that!!!!Guess I'll just live with the random MIL.
Told the wife that she's lucky the truck is in her name,I probably would of went to the other dealer on the way home and traded her in on a custom/sierra.Thats how much I hate that dam MIL.

Thanks
J
Reply With Quote
  #6  
Old 01-10-2014, 10:56 AM
GearHd6's Avatar
GearHd6 GearHd6 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2012
Location: CT
Age: 40
Posts: 169
Gender: Male
Vehicle: 2010 Ram 1500 CC
Trim Level: Big Horn
Color: Mineral Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:11
GearHd6 is on a distinguished road
Default

MIL's and CEL's are the wave of the future I think. I wouldn't expect any particular manufacturer to be any better in that regard. Some people get vehicles that treat them great and someone else will have the same vehicle that gives them nothing but headaches. It's all a gamble. If you don't want a CEL/MIL, buy a non computer non emissions truck. A nice 78 Power Wagon would be nice.

Hmmm..., now that I think of it. A 78 Power Wagon with a 5.9 Cummins manual pump engine, 6 speed manual with A/C?
Reply With Quote
  #7  
Old 01-10-2014, 04:15 PM
Bluedragon436's Avatar
Bluedragon436 Bluedragon436 is offline
Dodge Ram Forum Member
 
Join Date: Nov 2013
Location: Wherever the AF tells me to be!!
Posts: 68
Gender: Male
Vehicle: 2009 Ram 1500
Trim Level: SLT
Color: Brilliant Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Bluedragon436 is on a distinguished road
Default

Quote:
Originally Posted by GearHd6 View Post
A nice 78 Power Wagon would be nice.

Hmmm..., now that I think of it. A 78 Power Wagon with a 5.9 Cummins manual pump engine, 6 speed manual with A/C?
Agreed and AGREED~!!! Only issue I keep having pop up even though I've checked the tires multiple times is a random low tire press message.. other then that nothing yet, as far as MIL thank goodness... But I would love to find an old Power Wagon or even a decent shape M715 and an old school 5.9 Cummins back by a nice 6spd and maybe even the heavy duty axles from a Ram 2500 just to freshen up the drivetrain completely!!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:32 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum