DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Powertrain > Cummins Diesel Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #21  
Old 08-17-2013, 08:28 PM
mega charlie mega charlie is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2013
Location: Orlando
Age: 46
Posts: 2
Gender: Male
Vehicle: 2013 Ram 2500
Trim Level: Laramie Longhorn 4wd
Color: white
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
mega charlie is on a distinguished road
Question Check Engine Light / Malfunction Light

My malfunction/check engine came on at around 500 miles and I've got about 1300 now but it seems to be running just fine. I read in the owners manual that it could be bed fuel and to give it a few driving cycles ... Whatever that means. I'm taking it in next week. It was one week old when it popped up.
Reply With Quote
  #22  
Old 09-23-2013, 12:34 AM
Scjon03 Scjon03 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2009
Location: California
Age: 29
Posts: 77
Gender: Male
Vehicle: 2013 Ram 2500
Trim Level: Laramie Mega Cab
Color: Gray
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:71
Scjon03 will become famous soon enough
Default

My 2013 2500 CEL came on today. Sucks but I'm taking it in for the radio uconnect 13.31 update and the dealer told me about some other stuff that needs update as well. So hopefully it isn't anything bad.
__________________
2013 Ram 2500 Mega Cab Laramie 4x4
Reply With Quote
  #23  
Old 09-27-2013, 06:27 PM
mkozik1 mkozik1 is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2013
Location: Georgia
Posts: 2
Gender: Male
Vehicle: 2013 RAM 2500
Trim Level: Big Horn
Color: Black
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
mkozik1 is on a distinguished road
Default

I have 9,000 miles on my truck and have had this thing happen twice so far. I have only had the truck less than 4 months and tow a 15,000 lb 5th wheel camper. 90% of my travel is at highway speeds greater than 55 mph. Each time the regen has happened, I have been at highway speeds and it only took a few minutes for it to go from 100% to 50% to not there any more. about 15 minutes later, I get the check engine light.

Dealership told me they would have to wait for this to occur one more time before Chrysler would authorize the replacement because it is a $2500 part OR I could call Chrysler and generate a ticket and they would authorize it. That was three weeks ago and I keep dealing with the same questions and providing the same answers over and over. One time she says I idle too long, another is I don't drive highway speeds enough .... Getting ill just writing about it!!

Hope one of you can come up with a viable solution - I like the truck but this is killing me!!

Stay safe guys.
Reply With Quote
  #24  
Old 12-05-2013, 02:59 AM
RZBKH RZBKH is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2013
Location: Anchorage
Posts: 1
Gender: Male
Vehicle: 2013 Dodge Ram 2500
Trim Level: Laramie
Color: Metallic Gray
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
RZBKH is on a distinguished road
Default

I recently bought my Dodge Ram 2500 Mega Cab Diesel and I am having the exact same issue with the engine light and autostart. This really sucks when it is 20 below zero and after spending a lot of money on a new truck it doesn't work as needed. Short of this issue, I am very happy with the truck.
Reply With Quote
  #25  
Old 12-09-2013, 12:15 AM
ArcticR@m ArcticR@m is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2013
Location: Anchorage, Alaska
Posts: 5
Gender: Male
Vehicle: 2013 Ram 2500
Trim Level: Outdoorsman
Color: Midnight Blue
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
ArcticR@m is on a distinguished road
Default

I as well am having the same issue with the engine light and autostart. Hopefully it's nothing major, but still annoying for sure.
Reply With Quote
  #26  
Old 12-12-2013, 12:56 AM
ArcticR@m ArcticR@m is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2013
Location: Anchorage, Alaska
Posts: 5
Gender: Male
Vehicle: 2013 Ram 2500
Trim Level: Outdoorsman
Color: Midnight Blue
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
ArcticR@m is on a distinguished road
Default

I took what BeaverNation suggested and went out on the highway and ran it hard for about 30 minutes. Lo and behold, the check engine light is off now. I had been driving it recently in town so hopefully that's what was wrong.
Reply With Quote
  #27  
Old 12-22-2013, 05:08 PM
Mattz400 Mattz400 is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2010
Location: Central Illinois
Age: 38
Posts: 3
Gender: Male
Vehicle: 2013 Ram 2500
Trim Level: Laramie
Color: Copperhead Pearl
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
Mattz400 is on a distinguished road
Default

I join the crowd of the check engine light. I drive my truck pretty slow even on the highway. Bought it new in September and now have 10,000 miles on it. Lights on. The truck has only been in ReGen about three times since new, wonder why that is. I suppose I will have to try the greater highway speed idea and see what happens. This truck seems to have a few grimlins. Auto dimming lights are intermittent, the control screen, I think its the 8.4 a/n freezes up frequently and now the check engine light. Still love the truck but it does have its issues.
Reply With Quote
  #28  
Old 01-08-2014, 07:08 PM
marklaro marklaro is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2013
Location: Ontario
Age: 50
Posts: 2
Gender: Male
Vehicle: 2013 ram 2500 Diesel Longhorn
Trim Level: Longhorn
Color: White
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:38
marklaro is on a distinguished road
Default Check Engine Light

I guess I,m in the check engine light club to. My truck as been to the dealer 5 times for this issue. they order new sensors for the regain .and when it went on Monday they told me that dodge doesn't have a fix for it and that its the nox sensors that are freezing open and closed. and that the heat element in the tank takes to long to thaw out . so they told me to drive it like that till dodge finds a fix or to call customer service to complain . but with all of that I dindt have remote start because of the check engine light.So I went and got a after market remote install.So now the truck start every morning even if I got a service engine light on.
Reply With Quote
  #29  
Old 01-11-2014, 10:16 PM
ArcticR@m ArcticR@m is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2013
Location: Anchorage, Alaska
Posts: 5
Gender: Male
Vehicle: 2013 Ram 2500
Trim Level: Outdoorsman
Color: Midnight Blue
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
ArcticR@m is on a distinguished road
Default

I took my truck to Lithia for the Check Engine light again. Was told the same thing as marklaro. "Ram knows about it but there is no software fix for it yet. Just keep running it that way since it won't hurt the engine." Irritating to say the least. Spend that much money on a new truck and the manufacturer can't fix the problem
Reply With Quote
  #30  
Old 01-11-2014, 11:00 PM
hemi4452's Avatar
hemi4452 hemi4452 is offline
Dodge Ram Forum Member

 
Join Date: Dec 2013
Location: New York
Age: 45
Posts: 496
Gender: Male
Vehicle: 2013 ram crew cab sport
Trim Level: sport
Color: True blue pearl
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:69
hemi4452 will become famous soon enough
Default

My brothers 2013 2500 diesel has been in the shop to many times. Brought it in and on the way home same light. P2580 turbo speed sensor circuit low..
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:24 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum