DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #11  
Old 11-08-2013, 05:14 PM
Coach Borne Coach Borne is offline
Dodge Ram Forum Member
 
Join Date: Oct 2013
Location: Gramercy La
Age: 44
Posts: 55
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Big Horn
Color: Grey
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Coach Borne is on a distinguished road
Default

my dash lights turn red for a split second once and it hasn't happened since and I only have 1200 miles on my ram
Reply With Quote
  #12  
Old 11-08-2013, 06:51 PM
judger judger is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: Chatham NY
Age: 68
Posts: 22
Gender: Male
Vehicle: 2012 Dodge 3500
Trim Level: SLT
Color: Sagebrush
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
judger is on a distinguished road
Default

I have a 13 ram 3500, did the radio update and my amp gauge blinked for about 5 hours (returning home from Hershey car show ) . Has not done it since
Reply With Quote
  #13  
Old 12-31-2013, 06:14 PM
jaynuke jaynuke is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2010
Location: South Texas
Age: 55
Posts: 77
Gender: Male
Vehicle: 2013 Ram 2500 5.7L
Trim Level: Lone Star
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:14
jaynuke is on a distinguished road
Default

I've had my dash lights fiicker on low a couple of times also. Just haven't made it to the dealer yet.
Reply With Quote
  #14  
Old 01-19-2014, 07:23 PM
BgDannyP BgDannyP is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2013
Location: Fernie BC
Posts: 10
Gender: Male
Vehicle: 2013 Powerwagon
Trim Level: Power Wagon
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
BgDannyP is on a distinguished road
Default

I have the same issue I drive to work in the dark everyday, somedays it does it, some days it doesn't. I have had many electrical gremlins with my truck. There is a large wiring connector right where you put your left foor when you take it off the brake petal. My size 12's hit that connector all the time and unlock it, left me stranded and had the dealer figure out what it was. after being towed in. The wiring harness is pretty short and tight as well. A ziptie around the connector holds it locked, but I still have issues.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:14 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum