DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 1ST Generation Dodge Ram 1993 & Older Dodge Ram Trucks > Electrical
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

Electrical 1st Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #11  
Old 01-10-2010, 11:47 PM
Snowman's Avatar
Snowman Snowman is offline
Dodge Ram Forum Senior Member
 
Join Date: Dec 2009
Location: British Columbia
Age: 49
Posts: 200
Gender: Male
Vehicle: 2010 Cummins 3500 Crew cab
Trim Level: Laramie
Color: White/two tone
Engine: 2007-???? 409ci (6.7L) Cummins Turbo Diesel 350hp 650lb/ft
Rep Power: 0
Rep:34
Snowman is on a distinguished road
Default

Check voltage at back of alternator. If it reads 13.5v or better then you should perform a voltage drop test in posotve lead to battery. If it reads 12v or under suspect faulty alternator or regulator. Have had parts bad right out of the box a lot lately as quality conntrol is lame nowadays.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement







All times are GMT -4. The time now is 02:15 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors