DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > 4th Gen UConnect


Notices


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Total Load Control!
AutoAnything
Addictive Desert Designs!
FGT Motorsport
Bayou Goat Mounts
Mopar Online Parts!

Reply
 
Thread Tools
  #11  
Old 02-19-2014, 12:52 AM
hunter99 hunter99 is offline
Dodge Ram Forum Senior Member
 
Join Date: Aug 2013
Posts: 112
Gender: Male
Vehicle: 2013 R/T
Trim Level: R/T
Color: Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:22
hunter99 is on a distinguished road
Default

If it illuminates red you are supposed to get it serviced. Mine did that once and never came back. I had to have my radio replaced as they said it would fix the poor backup camera picture (it didn't) but have never seen that again. Otherwise everything works great except the washed out picture for the backup camera. Still dealing with that. There's nothing left for them to replace as they did the radio and the camera.
Reply With Quote
  #12  
Old 02-19-2014, 08:56 PM
RocketFoot's Avatar
RocketFoot RocketFoot is offline
Dodge Ram Forum Senior Member
 
Join Date: Dec 2013
Location: Southwestern PA
Posts: 415
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Big Horn
Color: Western Brown Monotone
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 3
Rep:78
RocketFoot will become famous soon enough
Default

Quote:
Originally Posted by hunter99 View Post
If it illuminates red you are supposed to get it serviced. Mine did that once and never came back. I had to have my radio replaced as they said it would fix the poor backup camera picture (it didn't) but have never seen that again. Otherwise everything works great except the washed out picture for the backup camera. Still dealing with that. There's nothing left for them to replace as they did the radio and the camera.
Yeah, my 911 button has been illuminated red since the day I got it!
__________________
Reply With Quote
  #13  
Old 06-27-2016, 07:53 PM
jimmerz's Avatar
jimmerz jimmerz is offline
Dodge Ram Forum Senior Member
 
Join Date: Apr 2014
Location: Pittsburgh
Age: 45
Posts: 248
Gender: Male
Vehicle: 2014 Ram 1500 CC Big Horn 4x4
Trim Level: Big Horn
Color: Dark Cherry Red
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
jimmerz is on a distinguished road
Default

My 2014 started doing this. My navigation maps are all messed up and I'm having BT connection issues. Figures this starts around 40,000miles! Grrrrrr
Reply With Quote
  #14  
Old 07-05-2016, 11:15 PM
kpc01 kpc01 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2016
Location: DFW TX
Age: 37
Posts: 3
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Laramie
Color: Red
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
kpc01 is on a distinguished road
Default

I just started having this problem on my '13 that I got in December of 13. Any chance since it affects 911 its covered still or is it on me to fix now? My gps is way off course and my clock is usually 10 minutes or so behind too. Has anyone found another fix for this yet outside of warranty? It seems like its an antenna problem
Reply With Quote
  #15  
Old 07-06-2016, 12:11 AM
Explorer Rob's Avatar
Explorer Rob Explorer Rob is offline
Dodge Ram Forum Senior Member
 
Join Date: Dec 2012
Location: Mesa, AZ
Age: 49
Posts: 1,565
Gender: Male
Vehicle: 2013 Ram 1500 4x4
Trim Level: Laramie Longhorn
Color: Black Gold / White Gold
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 4
Rep:281
Explorer Rob is a jewel in the roughExplorer Rob is a jewel in the roughExplorer Rob is a jewel in the rough
Default

Have you ever updated your U-Connect software? There was a fix many versions ago that fixed the "Phone requires service" message. You can update it yourself with a USB thumb drive by going to the U-Connect web-site. If your software is the latest then yes if you are out of the bumper to bumper warranty, it would be on you to pay for the fix.
Reply With Quote
  #16  
Old 07-06-2016, 12:25 PM
kpc01 kpc01 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2016
Location: DFW TX
Age: 37
Posts: 3
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Laramie
Color: Red
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
kpc01 is on a distinguished road
Default

I thought I did but just checked and I'm on 15.26.1 now. I'll see if I can update it and fix anything. The crazy thing is it's been fine for 2+ years and suddenly started both of these problems at once.
Reply With Quote
  #17  
Old 07-06-2016, 05:32 PM
ramcares's Avatar
ramcares ramcares is offline
Dodge Ram Forum Senior Member
 
Join Date: Jan 2016
Location: Michigan
Posts: 307
Gender: Female
Vehicle: n/a
Trim Level: n/a
Color: n/a
Rep Power: 0
Rep:38
ramcares is on a distinguished road
Default

Quote:
Originally Posted by kpc01 View Post
I thought I did but just checked and I'm on 15.26.1 now. I'll see if I can update it and fix anything. The crazy thing is it's been fine for 2+ years and suddenly started both of these problems at once.
Hi kpco1,

The website to check if you have any updates is http://www.driveuconnect.com/software-update/

Just have your VIN handy!

Kori
Ram Social Care Specialist
Reply With Quote
  #18  
Old 07-06-2016, 06:08 PM
kpc01 kpc01 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2016
Location: DFW TX
Age: 37
Posts: 3
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Laramie
Color: Red
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
kpc01 is on a distinguished road
Default

Quote:
Originally Posted by ramcares View Post
Hi kpco1,

The website to check if you have any updates is http://www.driveuconnect.com/software-update/

Just have your VIN handy!

Kori
Ram Social Care Specialist

Thanks, I did the update today and after a fun 1.5hrs on the phone still the same results. When I get to unit 10 (embeded air card) it freezes up. Evidently the air card in these radios is the problem and it won't allow an update to go through. I've had it just over two years but the mileage is out of warranty so it looks like they want me to buy a whole new unit for my gps to work again..... My gps is off and my 3g is missing as well. After some time on google today looks like this is a known problem with Uconnect and the systems. The bad thing is they aren't doing anything to fix it if you are over 36k miles.
Reply With Quote
  #19  
Old 07-24-2016, 12:42 PM
jimmerz's Avatar
jimmerz jimmerz is offline
Dodge Ram Forum Senior Member
 
Join Date: Apr 2014
Location: Pittsburgh
Age: 45
Posts: 248
Gender: Male
Vehicle: 2014 Ram 1500 CC Big Horn 4x4
Trim Level: Big Horn
Color: Dark Cherry Red
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
jimmerz is on a distinguished road
Default

Quote:
Originally Posted by kpc01 View Post
Thanks, I did the update today and after a fun 1.5hrs on the phone still the same results. When I get to unit 10 (embeded air card) it freezes up. Evidently the air card in these radios is the problem and it won't allow an update to go through. I've had it just over two years but the mileage is out of warranty so it looks like they want me to buy a whole new unit for my gps to work again..... My gps is off and my 3g is missing as well. After some time on google today looks like this is a known problem with Uconnect and the systems. The bad thing is they aren't doing anything to fix it if you are over 36k miles.
Aren't you glad you paid the extra money for the upgraded Nav unit? I am really a little beyond pissed about this. I was a little frustrated when my 1 year Uconnect ended and I found that If I wanted to continue sending voice text messages while driving I needed to pay $15/month. I just shook my head at that price and moved on. Then my Vehicle Phone needing service message came on and I was like hmmm. I guess my 911 feature will not work? What if I am in an accident, that could be useful to have? But I am past the 36,000 miles so I would pay for that. Then my Nav maps were all screwed up. That is what put me over the edge. I get that I have to pay for upgraded Nav maps IF I want the CORRECT maps but the dam thing should work after 2 years of ownership. SO now I guess I would have to pay to replace the whole system (Just guessing it would be about $1-2000) and then what do it again in 2 years???

NO THANKS RAM!!!
Reply With Quote
  #20  
Old 09-19-2016, 08:16 PM
jptsr1 jptsr1 is offline
Dodge Ram Forum Senior Member
 
Join Date: Jun 2014
Age: 45
Posts: 103
Gender: Male
Vehicle: 2014 Ram 1500
Rep Power: 0
Rep:16
jptsr1 is on a distinguished road
Default

Just had this pop up today at 40k. I'm sick!!!
Reply With Quote
Reply

Bookmarks

Tags
1500, phone, service, uconnect, vehicle

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement







All times are GMT -4. The time now is 07:01 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.10 Beta 2
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
vB.Sponsors