DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-22-2014, 11:05 PM
sexyshelly sexyshelly is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2014
Location: Kennedy, texas
Age: 30
Posts: 1
Gender: Female
Vehicle: 2006
Color: maroon
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
sexyshelly is on a distinguished road
Default electrical help !!!!

my boyfriend and i were moving our trailer trailer.and the person who hooked up our trailer connecter didn't installe it correctly. And we left the trailer hooked up to the truck and put the battery from the truck and hooked it to the trailer for power. Well i started to smell something. Burning from inside the truck and the wiring was burning. Up we unplugged. The truck from trailer .and everything. Worked as normal. For about 4 months . And now our reverse lights stay on no break lights after trying to change the bulbs .and about a week after doing that. I was driving. The truck to a friends and when i went to leave,. The truck started but then died as soon as i put my foot on the break .finally the next day after having someone clean out the airmass flow sincer and check my battery. And valcum line the truck would go but not in reverse. Now my boyfriend has got the wiring harness took down from the taillights all of the way to the fuse box but still no power to the back taillights and the gadges barley even work but the truck turns over and wants to start but don't .any help please only way to get back and,forth to work and working out of town and don't know any one !!!!
Reply With Quote
Sponsored links
  #2  
Old 03-23-2014, 10:07 PM
Simple guy Simple guy is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2013
Location: Pottstown, Pa
Age: 27
Posts: 247
Gender: Male
Vehicle: 2003 Ram 1500
Trim Level: SLT QC 4x4
Color: Mineral grey
Engine: 2002-2003 360ci (5.9L) Magnum V8 245hp 335lb/ft
Rep Power: 2
Rep:109
Simple guy will become famous soon enoughSimple guy will become famous soon enough
Default

sounds like it should be taken in to a technician with electrical experience. This sounds like a severe issue. I hope it doesn't need a new wiring harness and pcm
__________________
Reply With Quote
  #3  
Old 03-24-2014, 08:13 PM
tjbiker031's Avatar
tjbiker031 tjbiker031 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2011
Location: Bradenton, FL
Age: 30
Posts: 307
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT - Quad Cab
Color: Graphite Metalic
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 4
Rep:118
tjbiker031 will become famous soon enoughtjbiker031 will become famous soon enough
Default

Yeah I would have to give you the same answer. It seems from what you mention, you have a major issue and you can make it worse if you are not careful
__________________
Show your thanks with the REP icon.

Get your Factory Manuals here!! <link fixed>
Reply With Quote
  #4  
Old 03-27-2014, 09:50 AM
easy e's Avatar
easy e easy e is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2014
Location: New York
Posts: 99
Gender: Male
Vehicle: 2007
Trim Level: SLT
Color: Silver
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:21
easy e is on a distinguished road
Default

Quote:
Originally Posted by Simple guy View Post
sounds like it should be taken in to a technician with electrical experience. This sounds like a severe issue. I hope it doesn't need a new wiring harness and pcm
X2!

If you can go back to the guy that did the install, I would do that ASAP.

It sounds as if he didn't even install a fuse at any point, which causes the burning wires. Not good at all.
__________________
2007 Hemi SLT 4x4 Quad Cab
260k miles and counting...
Reply With Quote
Reply

Bookmarks

Tags
electrical

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:58 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum