Gas Cap Loose light on - Page 2 - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > LD RAM - Ram 1500 Forum > 2010 Dodge Ram Forum

Dodge Dakota Dodge Durango Dodge Nitro Jeep
Diesel Forums!
Dodge Dakota Forum Dodge Durango Forum Dodge Nitro Forum Jeep Forum
Dodge Challenger Dodge Charger Chrysler 300 Dodge Magnum
Dodge Caliber
Dodge Challenger Forum Dodge Charger Forum Chrysler 300 Forum Dodge Magnum Forum


Notices

2010 Dodge Ram Forum For specific discussion of the new 2010 Dodge Ram!


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Place your Ad Here!

Reply
 
Thread Tools
  #11  
Old 01-14-2012, 10:12 PM
primo spaghetti's Avatar
primo spaghetti primo spaghetti is offline
Dodge Ram Forum Senior Member


 
Join Date: Nov 2011
Location: southern ontario
Posts: 2,306
Gender: Male
Vehicle: 2014 Ram Sport
Trim Level: Sport
Color: Maximum Steel Metallic
Rep Power: 8
Rep:912
primo spaghetti is a splendid one to beholdprimo spaghetti is a splendid one to beholdprimo spaghetti is a splendid one to beholdprimo spaghetti is a splendid one to beholdprimo spaghetti is a splendid one to beholdprimo spaghetti is a splendid one to beholdprimo spaghetti is a splendid one to beholdprimo spaghetti is a splendid one to behold
Default

well the gas light is out. it actually triggered the engine light yesterday as well so i took it to the dealer. apparently the there was a vacuum line off at the gas tank. the dealer was surprised that the engine light didnt come on when i first got the truck because in their opinion, it looked like the line had never been properly attached when it was manufactured?

oh well.

both lights gone now.
__________________
2014 Dodge Ram 4X4 Sport, BakFlip F1 cover, Weathertech DigiFit Liners, BedRug bed mat, PIAA Extreme White Fog Bulbs, ProComp 2.5" / 1.5" Nitro Level Lift, Zone Off Road Upper Control Arms, ProComp 5050 20" -12 offset, MT Deagan 38 35x12.5.20, iron Cross Step Bars, DeeZee Tail Gate Strut

I am the heir to the primo spaghetti sauce fortune!
Reply With Quote
Sponsored links
  #12  
Old 01-15-2012, 09:45 AM
ram71351's Avatar
ram71351 ram71351 is offline
Dodge Ram Forum Senior Member
 
Join Date: Jul 2010
Location: Louisiana
Posts: 260
Gender: Male
Vehicle: 2014 Dodge Ram Laramie
Trim Level: Laramie
Color: Black Gold Pearl
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:45
ram71351 is on a distinguished road
Default

Thanks for the update and glad all is fixed
Reply With Quote
  #13  
Old 03-28-2014, 05:13 PM
GRGLAG GRGLAG is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: WISCONSIN
Age: 54
Posts: 1
Gender: Male
Vehicle: 2009 Ram
Trim Level: SLT
Color: BLUE
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
GRGLAG is on a distinguished road
Default

My 09 has done this a few times. It will go away. Not sure what causes it, but don't waste money on a gas cap. That's not it.
Reply With Quote
  #14  
Old 08-29-2015, 03:07 PM
otter007 otter007 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2015
Location: san antonio
Age: 38
Posts: 2
Gender: Male
Vehicle: 2014 ram 1500 5.7 hemi
Trim Level: lonestar
Color: maximum steel metallic
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
otter007 is on a distinguished road
Default

I am having the same issue. It has been to the dealership twice, had smoke tests, codes checked and cleared, and both times as soon as I get it home, shut it off, and come back to drive it later...bammm...gas cap light and engine light come on. According to the dealership they have to get "Chrysler" involved because they can't find anything wrong with it.

P.S. if anyone has any ideals....pppllleeeaassseee share. getting frustrating having to leave it at the dealership a week at a time (or longer ) :/

Last edited by otter007; 08-29-2015 at 03:08 PM. Reason: added info
Reply With Quote
  #15  
Old 08-31-2015, 11:32 AM
HighSierra's Avatar
HighSierra HighSierra is offline
Dodge Ram Forum Senior Member
 
Join Date: Nov 2011
Location: New Brunswick, Canada
Age: 71
Posts: 262
Gender: Male
Vehicle: 2010 RAM 1500 SLT 4X4 HEMI
Trim Level: SLT
Color: Mineral Gray Metallic
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
HighSierra is on a distinguished road
Default

Here's another one. Last January I filled the tank, left the gas cap off (don't ask) and drove till I needed gas. When I got out I noticed the cap dangling. Flap was closed. No lights or codes.

Go figure.
__________________
2010 RAM,
2009 Chrysler 300 Touring
1996 RAM (sold, I'll miss her)
Reply With Quote
  #16  
Old 08-31-2015, 05:08 PM
sottis sottis is offline
Dodge Ram Forum Senior Member
 
Join Date: Sep 2010
Posts: 111
Gender: Male
Vehicle: 2010 Dodge Ram Laramie 4x4
Trim Level: Laramie
Color: Black
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
sottis is on a distinguished road
Default

Mine was the cap. OE cap never felt right to me, but lasted 4 years until light came on and would not go off after re-sealing the cap. Replaced cap and no more problem. New cap seems to fit better and 'click' better also.
Reply With Quote
  #17  
Old 09-04-2015, 05:27 PM
NS-Jeeper NS-Jeeper is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2015
Location: Langdon Alberta
Posts: 5
Gender: Male
Vehicle: 2010 Dodge Ram 2500
Color: Red
Engine: 2010-20?? 345ci (5.7L) Hemi V8 383hp 400lb/ft (2500/3500)
Rep Power: 0
Rep:10
NS-Jeeper is on a distinguished road
Default

its the charcoal canister, or the hoses that connect to it. I had the same problem. I took it to the dealership 3 times for a cost of over $700 dollars and all they replaced was the gas cap (must be made of gold lol) but it still happed so I called up and ripped them a new one and they changed the canister and it hasn't happened since.
As a side note the dealership said they even did the smoke test and couldn't find the problem before I made them change the canister (which would have been done under warranty) probably just trying to make me pay for the warranty work lol.

Last edited by NS-Jeeper; 09-04-2015 at 05:28 PM. Reason: spelling
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement








All times are GMT -4. The time now is 03:40 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors