DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 04-03-2014, 01:59 AM
03Ramtruck 03Ramtruck is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2014
Posts: 2
Gender: Male
Vehicle: 2003 Dodge Ram
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
03Ramtruck is on a distinguished road
Default Electrical problem

Hi,
I have a 2003 Dodge Ram 1500 and for some reason, my left side tail light doesn't work. In fact, I do not get power on the running wire for trailer connector, left tail light and left license plate light. Brake, reverse and turning lights work. I checked the wire and from what I've seen, there is nothing wrong with it. Fuses are good too. Does anyone have any idea what might be wrong? Thank you
Reply With Quote
Sponsored links
  #2  
Old 04-03-2014, 02:06 AM
RogerRamJet's Avatar
RogerRamJet RogerRamJet is offline
God Bless Texas!




 
Join Date: May 2013
Location: Mansfield, TX
Age: 50
Posts: 11,526
Gender: Male
Vehicle: 2005 Ram 1500
Trim Level: Lonestar QC
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 12
Rep:2929
RogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond repute
Default

Hi, and welcome to the Ram ForumZ. I invite you to stop by the Newbie Check In section and introduce yourself so other members can give you a proper howdoyado.

As far as your electrical problem, my first guess would be that you have a bad ground. Check the ground on your tails and license plate light. Secondly, swap the actual light board with the right side and see if it follows. It may be a bad circuit board. If that doesn't pan out, then get an electrical schematic for your truck and start tracing the wires back to the IPM (fuse box).
Any more questions, don't hesitate to ask and keep us updated on the progress.
__________________
Life is hard... It's harder if you're stupid!
Today is a good day to be a RAM owner!
Reply With Quote
  #3  
Old 04-03-2014, 12:20 PM
03Ramtruck 03Ramtruck is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2014
Posts: 2
Gender: Male
Vehicle: 2003 Dodge Ram
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
03Ramtruck is on a distinguished road
Default

I already switched the light board. If it were the ground, I'd have issues with the brake, reverse and blinker too since it's the same ground. I can't find the schematics for my truck either. I thought maybe some relay was not working properly but I don't know which one to look for. I also tracked the wire to the fuse box and as it comes out of the fuse box, I checked and it does have power there so somewhere between the fuse box and the tail lights is my problem but I can't figure what.

Last edited by 03Ramtruck; 04-03-2014 at 01:26 PM.
Reply With Quote
  #4  
Old 04-03-2014, 11:24 PM
RogerRamJet's Avatar
RogerRamJet RogerRamJet is offline
God Bless Texas!




 
Join Date: May 2013
Location: Mansfield, TX
Age: 50
Posts: 11,526
Gender: Male
Vehicle: 2005 Ram 1500
Trim Level: Lonestar QC
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 12
Rep:2929
RogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond repute
Default

Then you have a break in the wire. You need to get a manual with an electrical schematic and see what circuit they are on.
__________________
Life is hard... It's harder if you're stupid!
Today is a good day to be a RAM owner!
Reply With Quote
  #5  
Old 04-04-2014, 08:25 AM
nosu13 nosu13 is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2014
Location: Louisiana
Age: 38
Posts: 9
Gender: Male
Vehicle: 2003 Dodge Ram 1500
Trim Level: SLT
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:22
nosu13 is on a distinguished road
Default

i have had a similiar problem I solved it buy changing the entire strip in the rear which encompasses all bulbs. Havent had an issue since.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 06:30 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum