DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 04-12-2014, 01:28 PM
waterdogMP waterdogMP is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2014
Location: Springfield, MO
Age: 27
Posts: 8
Gender: Male
Vehicle: 2002 Dodge Ram 1500 Quad Cab
Trim Level: SLT Sport
Color: Graphite
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
waterdogMP is on a distinguished road
Default Dodge 4.7l issues, any advice?

Hey guys, this is my first post, so I hope it is in the right spot.
I have a 2002 Dodge Ram 1500 4.7l 4x4. Recently it threw an engine code, P0320, ignition distributor engine speed input circuit malfunction.

When the maintenance light is on The consistent symptoms are this:
The engine lacks power, and acts like it hits a rev limiter at 27-2800 rpms.
After driving it like this for an extended period of time (20 minutes) the transmission fails to shift properly throwing code p0700.

I reset the codes and it will run fine for 10-15 minutes. The truck also tries to die at idle at stop lights. I replaced the cam sensor and the map sensor within the last 2 months. Crank position sensor was replaced over 2 years ago, pulled it and didn't observe any damage.

So my question is, do you guys think t could be the crank sensor (the truck starts fine) or something else. Im stumped, please help.

PS: I know, I hate 4.7's too
Reply With Quote
Sponsored links
  #2  
Old 04-12-2014, 05:23 PM
RogerRamJet's Avatar
RogerRamJet RogerRamJet is online now
God Bless Texas!




 
Join Date: May 2013
Location: Mansfield, TX
Age: 49
Posts: 10,360
Gender: Male
Vehicle: 2005 Ram 1500
Trim Level: Lonestar QC
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 12
Rep:2929
RogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond repute
Default

Howdy Jason. Welcome to the Ram ForumZ. I invite you to stop by the Newbie Check In section and introduce yourself so other members can give you a proper howdoyado.

Yes, this is the right section. Great job! And for the record, I love my 4.7. In 130K+ miles, I haven't had a single issue.

My first guess would be the TPS. But, it could also be the CPS.
__________________
Life is hard... It's harder if you're stupid!
Today is a good day to be a RAM owner!
Reply With Quote
  #3  
Old 04-12-2014, 06:56 PM
waterdogMP waterdogMP is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2014
Location: Springfield, MO
Age: 27
Posts: 8
Gender: Male
Vehicle: 2002 Dodge Ram 1500 Quad Cab
Trim Level: SLT Sport
Color: Graphite
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
waterdogMP is on a distinguished road
Default

Thanks Roger. I've just had bad luck with the 4.7l. My first one blew at 95,000 miles and this one had to be rebuilt, I do all the proper maintenace, guess I just have a lead foot. I just bought the CPS and I plan on installing it around 2000 hrs central time, so I will keep you guys posted. Thanks Again.

Too bad it can't be bulletproof like my old 318...

Last edited by waterdogMP; 04-12-2014 at 06:58 PM. Reason: Addition
Reply With Quote
  #4  
Old 04-13-2014, 12:57 AM
RogerRamJet's Avatar
RogerRamJet RogerRamJet is online now
God Bless Texas!




 
Join Date: May 2013
Location: Mansfield, TX
Age: 49
Posts: 10,360
Gender: Male
Vehicle: 2005 Ram 1500
Trim Level: Lonestar QC
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 12
Rep:2929
RogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond repute
Default

Quote:
Originally Posted by waterdogMP View Post
Thanks Roger. I've just had bad luck with the 4.7l. My first one blew at 95,000 miles and this one had to be rebuilt, I do all the proper maintenace, guess I just have a lead foot. I just bought the CPS and I plan on installing it around 2000 hrs central time, so I will keep you guys posted. Thanks Again.

Too bad it can't be bulletproof like my old 318...



Arguably one of the best, if not THE best, production engine ever made.

Hey, you're welcome. Well, it's almost zero hundred so hopefully you got the CPS installed and all is well.
__________________
Life is hard... It's harder if you're stupid!
Today is a good day to be a RAM owner!
Reply With Quote
  #5  
Old 04-13-2014, 01:03 AM
maust1's Avatar
maust1 maust1 is offline
Dodge Ram Forum Senior Member!

 
Join Date: May 2013
Location: Hamilton Tx
Age: 32
Posts: 515
Gender: Male
Vehicle: 2013 Ram
Trim Level: Tradesman
Color: mineral grey
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 2
Rep:355
maust1 is just really nicemaust1 is just really nicemaust1 is just really nicemaust1 is just really nice
Default

It almost sounds like an EGR issue if you go by the symptoms. I hope you get it figured out.
Mick
P.S. I love my 4.7L swell sorry yours has given you so much trouble
Reply With Quote
  #6  
Old 04-13-2014, 01:40 AM
RogerRamJet's Avatar
RogerRamJet RogerRamJet is online now
God Bless Texas!




 
Join Date: May 2013
Location: Mansfield, TX
Age: 49
Posts: 10,360
Gender: Male
Vehicle: 2005 Ram 1500
Trim Level: Lonestar QC
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 12
Rep:2929
RogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond repute
Default

Quote:
Originally Posted by maust1 View Post
It almost sounds like an EGR issue if you go by the symptoms. I hope you get it figured out.
Mick
P.S. I love my 4.7L swell sorry yours has given you so much trouble
You make a great point, Mick. I reckon we'll find out tomorrow.
__________________
Life is hard... It's harder if you're stupid!
Today is a good day to be a RAM owner!
Reply With Quote
  #7  
Old 04-13-2014, 01:40 PM
waterdogMP waterdogMP is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2014
Location: Springfield, MO
Age: 27
Posts: 8
Gender: Male
Vehicle: 2002 Dodge Ram 1500 Quad Cab
Trim Level: SLT Sport
Color: Graphite
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
waterdogMP is on a distinguished road
Default

Update:

The Auto Parts store gave me the wrong sensor. So i wasn't able to get it installed and wont be able to get another one until Monday. Unfortunately I won't be able to determine the cause until then. Thanks again for the advice guys, I really appreciate it. Mick-Good point, that will be my next approach.
Reply With Quote
  #8  
Old 04-13-2014, 07:38 PM
RogerRamJet's Avatar
RogerRamJet RogerRamJet is online now
God Bless Texas!




 
Join Date: May 2013
Location: Mansfield, TX
Age: 49
Posts: 10,360
Gender: Male
Vehicle: 2005 Ram 1500
Trim Level: Lonestar QC
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 12
Rep:2929
RogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond repute
Default

Doggone amateur parts store pukes!!!
__________________
Life is hard... It's harder if you're stupid!
Today is a good day to be a RAM owner!
Reply With Quote
  #9  
Old 04-13-2014, 11:49 PM
maust1's Avatar
maust1 maust1 is offline
Dodge Ram Forum Senior Member!

 
Join Date: May 2013
Location: Hamilton Tx
Age: 32
Posts: 515
Gender: Male
Vehicle: 2013 Ram
Trim Level: Tradesman
Color: mineral grey
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 2
Rep:355
maust1 is just really nicemaust1 is just really nicemaust1 is just really nicemaust1 is just really nice
Default

Quote:
Originally Posted by waterdogMP View Post
Update:

The Auto Parts store gave me the wrong sensor. So i wasn't able to get it installed and wont be able to get another one until Monday. Unfortunately I won't be able to determine the cause until then. Thanks again for the advice guys, I really appreciate it. Mick-Good point, that will be my next approach.
I just hope it helps.
Reply With Quote
  #10  
Old 04-15-2014, 07:03 PM
waterdogMP waterdogMP is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2014
Location: Springfield, MO
Age: 27
Posts: 8
Gender: Male
Vehicle: 2002 Dodge Ram 1500 Quad Cab
Trim Level: SLT Sport
Color: Graphite
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
waterdogMP is on a distinguished road
Default

Good news, after finally getting the correct sensor, I installed the CPS and boom it works! Thanks guys for all your help. I'm proud to be a part of your community.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:17 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum