DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 1ST Generation Dodge Ram 1993 & Older Dodge Ram Trucks > Electrical


Electrical 1st Gen Dodge Ram Electrical Problems and Questions.

Latest Vendor News
Addictive Desert Designs!
Bayou Goat Mounts

Thread Tools
Old 05-05-2014, 05:26 PM
rammerhard rammerhard is offline
Dodge Ram Forum Newcomer
Join Date: Mar 2014
Age: 34
Posts: 1
Gender: Male
Vehicle: 2010 dodge ram
Rep Power: 0
rammerhard is on a distinguished road
Default is this an electrical issue??

hi everyone, i have a 2010 dodge ram with the hemi in it and the other day while i was driving on the highway the motor revved up and all of a sudden died. when i triied to re-start it again all it does is click the starter against the fly-wheel but it doesnt actually crank it over. i was told theres some kind of trans sensor that can cause the motor to go into safe mode and it wont spin after that point but i dont want to start messing with a bunch of things i dont know much about. Any help would be MAJORLY appreciated cause im at a loss as to what to check next. thx!
Reply With Quote
Sponsored links


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:30 AM.

= Copyright a Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.