DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 1ST Generation Dodge Ram 1993 & Older Dodge Ram Trucks > Electrical


Notices

Electrical 1st Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-08-2014, 08:54 PM
matthewbowser matthewbowser is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2014
Location: Memphis
Age: 32
Posts: 1
Gender: Male
Vehicle: 1984 D150
Color: Grey
Engine: 1981-1987 318ci (5.2L) LA V8 140hp
Rep Power: 0
Rep:10
matthewbowser is on a distinguished road
Default Electronic T'stat Module, AC Diagram, and White Smoke 1984 D150

So, I bought a really straight and clean barn kept 1983-84 (built in 8/83) Dodge Ram Pickup for 900 bucks from a kid in Nashville. The interior is immaculate and the body is really straight...the engine and transmission are both very strong....I have a series of questions:

1. There was an UNMARKED blue box containing a circuit board behind the dash. I am certain it connects to the AC/HEATER?DEFROST slider switch on the AC unit. There are NO markings on the box to help find the part. I need a new part because the one I pulled was fried...like caught on fire and melted. I know it is part of my problem because when I slide the selector switch from AC to heat OR defrost the blower motor cuts out. The blower works GREAT (at all three speeds) when AC is selected, but as soon as the slider hits HEAT OR DEFROST the blower cuts out. So I went to the junk yard to see if I could find a similar part...I found an 86 dodge ram SWB and it had different components, but I did find a module in the same place that ALSO had a potentiometer on the circuit board LIKE the original UNMARKED part and it says, "Electronic T'Stat Module" which I assume means Electronic THERMOSTAT Module......

2. My truck has all the components for the AC to work, but someone ripped the wiring up UNDER the hood. Does anyone have a schematic or diagram?

3. Lastly, upon start up, my truck smokes white smoke...NOT CONDENSATION...could it be caused by sticking valves?

Any guidance on these things would be GREATLY appreciated!!!!
Reply With Quote
Sponsored links
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 01:18 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum