DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.

Latest Vendor News
Addictive Desert Designs!
Bayou Goat Mounts

Thread Tools
Old 07-19-2014, 07:52 PM
sleeper1 sleeper1 is offline
Dodge Ram Forum Newcomer
Join Date: Jul 2014
Location: atlanta ga.
Age: 71
Posts: 2
Gender: Male
Vehicle: 2004 dodge ram 2500 diesel
Trim Level: laramie
Color: red
Engine: 2004-2004 359ci (5.9L) Cummins ISB 600 24-Valve Diesel I6 325hp 600lb/ft (6-Speed Manual)
Rep Power: 0
sleeper1 is on a distinguished road
Default "no bus" display

2004 2500 diesel. No bus display shows on mileage indicator. All gauges go to zero and brake light, gas pump light, abs, check engine indicator, etc come on. Will not start if "no bus" is displayed, but will stay running if "no bus" indicator comes on. Any help will be appreciated. Thanks
Reply With Quote
Sponsored links


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:58 AM.

= Copyright a Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.