DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2014 Dodge Ram Forum


Notices

2014 Dodge Ram Forum For specific discussion of the 2014 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-20-2014, 08:54 PM
SmoothVanilla's Avatar
SmoothVanilla SmoothVanilla is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2013
Location: Edmonton
Posts: 152
Gender: Male
Vehicle: 2014 RAM sport QC
Trim Level: Sport
Color: Blue Streak
Rep Power: 0
Rep:12
SmoothVanilla is on a distinguished road
Default question about TPMS in 2014 Ram

hey guys. So when I traded in my 13 sport for my 14 sport I kept my aftermarket wheels/ tires and put them on my 14. Little did I know for some stupid reason the tire sensors are NOT the same from 13 to 14, so they do not work properly. I know these trucks supposedly have a "winter mode" but I am curious if anyone can shed any more details on this. In my truck now the SERVICE TPMS message and light go away after a day or 2, but I still need to change the display on the EVIC screen every time I start the truck . Also once every 2 weeks the truck will recognize the faulty sensors and start the whole cycle all over again. So basically what I am trying to ask is if I actually REMOVE the sensors from the tires, will this properly engage the so called winter mode, or is this normal behavior for the winter mode? Sorry for the long post and any help would be greatly appreciated as I cannot seem to find much on this winter mode. Thanks
__________________
2014 RAM sport QC 3:92 Blue Streak
Reply With Quote
Sponsored links
  #2  
Old 07-20-2014, 10:50 PM
Rambunkshuss Rambunkshuss is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2011
Location: PA
Posts: 1,045
Gender: Male
Vehicle: 2014 Dodge Ram
Trim Level: Sport
Color: Black
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:72
Rambunkshuss will become famous soon enough
Default

I`m not sure of this, but see if the dealer can re-flash it to the wheels you now have on the truck.
Reply With Quote
  #3  
Old 07-21-2014, 12:50 AM
Ron4969's Avatar
Ron4969 Ron4969 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Oct 2013
Location: Northern BC, Canada
Posts: 102
Gender: Male
Vehicle: 2014 Ram 1500
Trim Level: Limited eco-diesel
Color: Deep cherry red
Engine: 2014-20?? 182.3ci (3.0L) L630DOHC V6 240hp 420lb/ft Eco-Diesel
Rep Power: 0
Rep:10
Ron4969 is on a distinguished road
Default

I asked my dealer (service dept) about this "winter mode" and they had never heard of it. I think the best and only alternative is to purchase the 2014 sensors and have them installed. On a previous post someone had purchased a set of 4 from Amazon for $109. I am going to look into that soon as I have already purchased a used set of 2013 Sport style wheels which I will mount Blizzaks on and put on my 2014 Limited.
Reply With Quote
  #4  
Old 07-21-2014, 06:03 PM
SmoothVanilla's Avatar
SmoothVanilla SmoothVanilla is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2013
Location: Edmonton
Posts: 152
Gender: Male
Vehicle: 2014 RAM sport QC
Trim Level: Sport
Color: Blue Streak
Rep Power: 0
Rep:12
SmoothVanilla is on a distinguished road
Default

damn. Everywhere I look it's going to cost close to $300 once all is said and done. I think I might remove the sensors and see if it works.
__________________
2014 RAM sport QC 3:92 Blue Streak
Reply With Quote
  #5  
Old 07-21-2014, 06:15 PM
finn5033's Avatar
finn5033 finn5033 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2013
Location: MN
Posts: 753
Gender: Male
Vehicle: 2014 Ram 1500 cc 4x4
Trim Level: Outdoorsman
Color: Granite
Engine: 2013-20?? 220ci (3.6L) Pentastar 305hp 269lb/ft
Rep Power: 0
Rep:24
finn5033 is on a distinguished road
Default

Quote:
Originally Posted by SmoothVanilla View Post
damn. Everywhere I look it's going to cost close to $300 once all is said and done. I think I might remove the sensors and see if it works.
If your going to pay to have the sensors removed you may as well have the correct ones installed. If you just remove the current ones and it doesn't work it's just going to cost you more in the long run
Reply With Quote
  #6  
Old 07-22-2014, 06:08 PM
SmoothVanilla's Avatar
SmoothVanilla SmoothVanilla is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2013
Location: Edmonton
Posts: 152
Gender: Male
Vehicle: 2014 RAM sport QC
Trim Level: Sport
Color: Blue Streak
Rep Power: 0
Rep:12
SmoothVanilla is on a distinguished road
Default

^^ this is true. What I meant to say is I will remove them when I balance my winter tires and go from there. I am not paying for 2 sets of tpms lol.
__________________
2014 RAM sport QC 3:92 Blue Streak
Reply With Quote
  #7  
Old 07-24-2014, 08:49 AM
mechtech mechtech is offline
Dodge Ram Forum Junior Member
 
Join Date: Jun 2013
Location: Winnipeg,Manitoba
Posts: 41
Gender: Male
Vehicle: 2014 Dodge Ram
Trim Level: Sport Quad
Color: silver
Rep Power: 0
Rep:10
mechtech is on a distinguished road
Default

I had the same problem.Traded in my 2013 for a 2014.Different sensors on the 2014.The truck will only go into winter mode if there are NO sensors in the wheels and tires.I had to remove the sensors from my 2013 wheels and winter tires and now it goes into winter mode after about 12 start stop sequences.It was my dealership that gave me the info.Other solution is to buy the 2014 sensors and replace the 2013 sensors.Hope this helps.
Reply With Quote
  #8  
Old 07-24-2014, 08:07 PM
SmoothVanilla's Avatar
SmoothVanilla SmoothVanilla is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2013
Location: Edmonton
Posts: 152
Gender: Male
Vehicle: 2014 RAM sport QC
Trim Level: Sport
Color: Blue Streak
Rep Power: 0
Rep:12
SmoothVanilla is on a distinguished road
Default

Ok so what you are saying is once you removed the sensors completely the truck basically ignores them all together after so many starts? No messages in the EVIC or anything? Thanks so much for the reply.
After so many starts my truck will "act" like everything is fine (no light on the dashboard e.c.t), but The image of the truck and dashes in 4 corners still comes on every time I start it. I have no problem replacing the sensors in the summers but I won't be replacing the winters.
__________________
2014 RAM sport QC 3:92 Blue Streak

Last edited by SmoothVanilla; 07-24-2014 at 08:10 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:55 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum