DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > LD RAM - Ram 1500 Forum > 2009 Dodge Ram Forum


Notices

2009 Dodge Ram Forum For specific discussion of the 2009 Dodge Ram!


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Total Load Control!
Dodge Ram Decals
AutoAnything
Addictive Desert Designs!
FGT Motorsport
Bayou Goat Mounts
FGT Motorsport
Mopar Online Parts!

Reply
 
Thread Tools
  #1  
Old 08-13-2014, 08:14 AM
bstc00's Avatar
bstc00 bstc00 is offline
Dodge Ram Forum Senior Member
 
Join Date: May 2011
Location: MI
Age: 32
Posts: 1,104
Gender: Male
Vehicle: 2009 Ram 1500
Trim Level: Sport
Color: Inferno Red
Rep Power: 6
Rep:207
bstc00 has a spectacular aura aboutbstc00 has a spectacular aura aboutbstc00 has a spectacular aura about
Default towing

I have an 09 sport crew. I have been towing with it since day one. For some reason the brakes don't work with the trailer anymore. I had the trailer looked at and the brakes work on the the trail but when its attached to the truck nothing happens. Is there a fuse on the truck or do you think that my trail brake controller is broken. When I push the brake button on the controller it tells me there is nothing connected to it. Any help would be great.

Thanks
Reply With Quote
Sponsored links
  #2  
Old 08-13-2014, 10:32 AM
Hermes1 Hermes1 is offline
Dodge Ram Forum Senior Member
 
Join Date: Jan 2013
Location: USA
Posts: 2,684
Gender: Male
Vehicle: A Truck
Rep Power: 11
Rep:2559
Hermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond repute
Default

It is possible there is a problem with your BC, but it is more likely there is a bad connection. Looking for a bad fuse is worth a start. Then I would spray some electric contact cleaner into both connections (trailer & truck sides) and maybe some mechanical means to scrape the contacts. If that does not solve the problem a multimeter will come in handy to look for a broken or compromised wire in the trailer or the truck. If all wires test functional, likely the BC may have gone bad, but also make sure you still have a sound connection at the BC.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement







All times are GMT -4. The time now is 09:29 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.10 Release Candidate 2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors


Sponsor Ad: Get Free Shipping and Discount Prices on Auto Parts at AutoAnything ranging from seat covers & truck bed covers to air intakes & exhaust systems from Extang, Magnaflow, K&N & Hypertech. They carry all sorts of Dodge Ram Accessories to choose from, like: Dodge Ram exhaust, Ram cold air intakes, Ram nerf bars, Dodge Ram seat covers and more.

Use the coupon code FRMRAM10 to receive 10% off orders over $150 when you order from the AutoAnything Ride Pros!