DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-28-2010, 05:01 PM
cashman36 cashman36 is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2010
Age: 39
Posts: 2
Gender: Male
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
cashman36 is on a distinguished road
Default Code P0340 and P0443

2000 Dodge Ram 1500, 5.9L. Since Nov my truck has had three occurrances that it wouldn't start. After being patient for 30 mins or so it would finally start perfectly. Engine would turn over fine, just not start. I'm getting two codes, P0340 and P0443. One being a CAMshaft sensor. None of the autoparts stores around here carry a CAMshaft Sensor. All have a crankshaft sensor. Can you tell me what the issue is? And if I need a CAMshaft sensor, where can I get one?
Reply With Quote
Sponsored links
  #2  
Old 02-28-2010, 05:08 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member



 
Join Date: Nov 2009
Location: Tennessee
Age: 44
Posts: 13,476
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Rep Power: 15
Rep:1909
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

The cam sensor is in the distributor on your truck. You may wind up going to the dealership for one if the parts stores can't order one for you. The P0443 indicates a problem with your EVAP purge solenoid, wiring or the PCM.
Reply With Quote
  #3  
Old 02-28-2010, 07:07 PM
cashman36 cashman36 is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2010
Age: 39
Posts: 2
Gender: Male
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
cashman36 is on a distinguished road
Default

Thanks Randy. So can I just replace the distributor cap and button, or is the Cam sensor in additon to those items? I'm assuming located inside the cap, but probably under the button.

Thanks,

Jamie
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 11:09 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors