DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-20-2010, 10:35 AM
latitud's Avatar
latitud latitud is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2010
Location: Southwest VA
Age: 43
Posts: 571
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: SLT
Color: Deep Water Pearl
Rep Power: 0
Rep:71
latitud will become famous soon enough
Default abs and brake light in the cluster

Well as I continue to find issues with the newly aquired truck, I am geting to them as I have time. Currently I am working on replacing the recirc door as mine is completely missing. Obviously the last owner had the HVAC serviced as it has several missing screws..but this isn't what I have a question on.

My question is that my instrument cluster has a few issues. When I first bought the truck, 9 out of 11 dash lights were burnt out. I replaced them and noticed that my emergency brake could be on and the light on the dash isn't on. I did the cluster diagnostics and the ABS light and the brake lights neither one light up. I have read that they are both LED's and are non serviceable and the cluster must be replaced....that seems expensive. So my questions are:
1. If I replace the cluster, how do I get the new cluster to register the correct mileage from the old cluster?
2. Do I just transfer the old keyless module from the back of the old one to the new one.
3. Is it possible to just solder new led's onto the existing board? and if so, what voltage led's should I use?

During the diagnostics I get and 03 ABS indicator output circuit shorted and 06 MIL indicator output circuit open and 64 Driver door lock switch input circuit open. I assume the 03 and 06 are a result of the fact that the LED's do not light up...does that sound correct?

Now judging from the fact that I can tell the Instrument cluster has been apart before I am wondering what could have happened to the led's since I can't imagine they would ever go out.

I find little things all the time, which I guess is normal when buying a used truck.

__________________
2010 Dodge Ram, 5.7 Hemi, Crew Cab
Reply With Quote
Sponsored links
  #2  
Old 07-21-2010, 06:39 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

If I'm not mistaken, no programming is needed for the '03 cluster. If you're referring to the security key module, it's not built into the cluster. Never tried soldering in new LED's but a good electronic repair shop should be able to help you out.
Reply With Quote
  #3  
Old 07-21-2010, 11:59 PM
latitud's Avatar
latitud latitud is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2010
Location: Southwest VA
Age: 43
Posts: 571
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: SLT
Color: Deep Water Pearl
Rep Power: 0
Rep:71
latitud will become famous soon enough
Default

no security key required on mine. No transponder keys.
I mean if I have to replace the cluster with a new or used one, how do I get the mileage correct on the new one?
__________________
2010 Dodge Ram, 5.7 Hemi, Crew Cab
Reply With Quote
  #4  
Old 07-27-2010, 03:15 PM
latitud's Avatar
latitud latitud is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2010
Location: Southwest VA
Age: 43
Posts: 571
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: SLT
Color: Deep Water Pearl
Rep Power: 0
Rep:71
latitud will become famous soon enough
Default

I got the cluster pulled and noticed a few screws were missing from the plastic cover that covered the circuit board. Once I got the cover off, I could see that one of the resistors labeled "621" was split in half and it was right in the area of where the ABS and BRAKE light would be. I can't see any way to repair this, so it looks like I am gonna need a new cluster.
__________________
2010 Dodge Ram, 5.7 Hemi, Crew Cab
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 01:58 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum