DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2010 Dodge Ram Forum


Notices

2010 Dodge Ram Forum For specific discussion of the new 2010 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-23-2010, 02:33 PM
thedraco's Avatar
thedraco thedraco is offline
Dodge Ram Forum Junior Member
 
Join Date: Jul 2010
Location: Edmonton, AB, Canada
Age: 30
Posts: 34
Gender: Male
Vehicle: 2010 Ram 1500
Trim Level: SXT Crew
Color: Inferno Red
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
thedraco is on a distinguished road
Default Pedal Squeak

My brake pedal has a squeak to it now at 3800 kms, more noticeably on rainy and humid days. I'll probably live with it until the first oil change, and tell them then rather then make separate trips. I was wondering if there's any service bulletins or if anyone else has experienced this because knowing my luck they won't be able to "reproduce the problem" and I'll but stuck with this annoying squeak forever.
Reply With Quote
Sponsored links
  #2  
Old 08-24-2010, 08:04 AM
HEMILANCER's Avatar
HEMILANCER HEMILANCER is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2009
Location: Ponchatoula, La
Age: 36
Posts: 344
Gender: Male
Vehicle: 09 Dodge Ram
Trim Level: Sport
Color: deep water blue
Rep Power: 6
Rep:85
HEMILANCER will become famous soon enough
Default

its the brake booster. mine does it only in winter. the dealer has to hear it to warranty it, of course when i did bring mine in in spring it didn't make noise. so this winter i'm ready.
__________________
Too many mods to fit here!
Reply With Quote
  #3  
Old 08-24-2010, 08:49 AM
erm
Guest
 
Posts: n/a
Default

You don't have to live with it. Just get an idea of where it's at, get some white lithium grease or some other long lasting spray lube and give it a shot.
Reply With Quote
  #4  
Old 08-24-2010, 04:06 PM
dtownkcufo's Avatar
dtownkcufo dtownkcufo is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2010
Location: Methlehem Mo.
Age: 37
Posts: 79
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: SLT QC 4x4
Color: Mineral Gray
Rep Power: 0
Rep:33
dtownkcufo is on a distinguished road
Default

I've got the same problem. Sitting at 6000 miles. When I go in for an oil change I'm going to have them fix it.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:01 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum