DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 05-12-2010, 11:04 PM
lifted47 lifted47 is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2010
Posts: 1
Gender: Male
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
lifted47 is on a distinguished road
Default 2003 ram 1500 over heated

rmy 2003 dodge 1500 over heated when i was going down the freeway i got it home and changed out the thermostat and the radiator and now it wont idle so i changed out the spark plugs and now it wont idle still i got a check engine light for my tps would that be doing all this cuz my head gasket is still in tacked i dont have creamy oil and there wasnt any coolant in my spark plugs so could my tps be the cure to all this
__________________
2003 4.7L
Reply With Quote
Sponsored links
  #2  
Old 05-12-2010, 11:27 PM
City Slicker City Slicker is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Posts: 11,861
Gender: Male
Rep Power: 14
Rep:1625
City Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant futureCity Slicker has a brilliant future
Default

Welcome to the forum! Glad to have you here! Sorry I'm no help, I'll leave this one to the professionals on here
Reply With Quote
  #3  
Old 06-10-2010, 11:51 AM
GaryGtx GaryGtx is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2010
Location: White Settlement, Texas
Age: 30
Posts: 22
Gender: Male
Vehicle: 2002 Dodge Ram quad cab 4.7l
Trim Level: slt
Color: light blue
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
GaryGtx is on a distinguished road
Default

nope could be temp sensor! the old 5.2 and 5.9 had 2 sensors one for the temp gauge and one for the pcm. If the one for he pcm went out then the motor would not ever idle! not sure if the 4.7 isthe same way but it sounds like the same issue.
Reply With Quote
  #4  
Old 06-22-2010, 11:40 AM
fixitfirstime's Avatar
fixitfirstime fixitfirstime is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2009
Posts: 18
Gender: Male
Engine: 2008-2008 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:10
fixitfirstime is on a distinguished road
Default

So if you unplug the temp sensor and put it in open loop does it run better and idle then?
Reply With Quote
  #5  
Old 06-25-2010, 12:01 PM
RamCountry's Avatar
RamCountry RamCountry is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2010
Location: Jacksonville, FL
Age: 26
Posts: 193
Gender: Male
Vehicle: 2006 Dodge Ram
Trim Level: Reg. Cab Laramie 4x4
Color: Atlantic Blue Pearlcoat
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:64
RamCountry will become famous soon enough
Default

it wouldnt make it any better open loop makes it think its 52 below so it makes it super rich and usually bogs it out at least on most cars its that way lol you need to take it to a shop that has a scanner that can read real-time data and see what it says
Reply With Quote
  #6  
Old 08-28-2010, 02:33 AM
DodgieDan DodgieDan is offline
Dodge Ram Forum Member
 
Join Date: Aug 2010
Location: Victoria, BC
Age: 64
Posts: 56
Gender: Male
Vehicle: 2003 Dodge Ram 1500 Quad Cab
Trim Level: SLT
Color: Red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
DodgieDan is on a distinguished road
Default

Need to know what codes you are getting with the check engine light much easier to diagnose a problem using them then just guessing it needs this that or the other thing to fix it.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 02:11 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum