DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Heating & Cooling


Notices

Heating & Cooling 3rd Gen Dodge Ram Heating & Cooling Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-07-2010, 04:52 PM
threetime threetime is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2010
Age: 42
Posts: 2
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
threetime is on a distinguished road
Default AC Blower issue.

Oh, by the way, hello everyone. Back to the problem. I think I already know the answer to this but here goes. I have an 04 dodge ram 1500 4X4. Two days ago the AC worked fine. Then after work, I got in, turned the AC on and it was barely putting out. I can hear the fan motor running fine. The hi, med, low works fine. The selector works fine. I think something came unhooked, like the main flow tube and its blowing the cold air in the dash. Question, anyone think I have a different problem? How hard is this going to be to fix?
Reply With Quote
Sponsored links
  #2  
Old 08-07-2010, 10:46 PM
threetime threetime is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2010
Age: 42
Posts: 2
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
threetime is on a distinguished road
Default

***UPDATE***

OK, I have tore into the dash with amazing speed. The weird thing is I can see the top of the hvac unit and look all the way to the firewall and can see the freshair grill. I can stick my hand in there and it feels like the air is blowing out the vents and also where the fresh air comes in. I am not sure if there is some kind of flap that is not closing??? Help please.
Reply With Quote
  #3  
Old 08-08-2010, 10:55 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

You've probably got a broken recirc door. Very common problem.
Reply With Quote
  #4  
Old 08-15-2010, 10:31 AM
KC Chally Snob's Avatar
KC Chally Snob KC Chally Snob is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2010
Location: we live in Blue Springs Mo. its just out side Kansas City Mo.
Age: 57
Posts: 145
Gender: Male
Rep Power: 0
Rep:18
KC Chally Snob is on a distinguished road
Default

Threetime,

I had the exact same problem up until yesterday. I got a new recirc housing, 75.00, from the local Dodge dealer, and proceeded to remove the dash. Now I have a 2003 1500 Quad cab and Randy was kind enough to have posted the instructions on how to remove the dash, but I didn't remove dash completely. I just took enough off, which would have allowed me to remove the dash because all the bolts holding it to the vehicle were removed, to pull the rights side of the dash back enough to get the old housing out and the new one in. Look here on the form for recirc door posts and you should be able to find Randy's earlier post with detailed intructions.
Good Luck.

KC Chally Snob
AKA Larry
Reply With Quote
  #5  
Old 09-18-2010, 07:31 PM
wissuffa wissuffa is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2010
Age: 54
Posts: 3
Gender: Male
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
wissuffa is on a distinguished road
Default

simiar problem here 2003 Ram 1500 blower motor not blowing checked all the fuses and disconnected the blower motor did a test on it with the battery and it worked fine but when hooked to the connections it's not working anyone have similar issues
Reply With Quote
  #6  
Old 09-18-2010, 07:49 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Quote:
Originally Posted by wissuffa View Post
simiar problem here 2003 Ram 1500 blower motor not blowing checked all the fuses and disconnected the blower motor did a test on it with the battery and it worked fine but when hooked to the connections it's not working anyone have similar issues
Do you have power on the dark green wire to the blower motor with the key in the run position?
Reply With Quote
  #7  
Old 09-18-2010, 08:48 PM
wissuffa wissuffa is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2010
Age: 54
Posts: 3
Gender: Male
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
wissuffa is on a distinguished road
Default

no power to green wire
Reply With Quote
  #8  
Old 09-18-2010, 09:21 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

You have an ignition switch problem or a break in the green wire.
Reply With Quote
  #9  
Old 09-18-2010, 10:04 PM
wissuffa wissuffa is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2010
Age: 54
Posts: 3
Gender: Male
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
wissuffa is on a distinguished road
Default

thanks, i just had to change te key cylinder and prior to that the blower would cut n-off and i thought it was the ignition switch but i changed the key cylinder thanks for the info much appreciated!!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:20 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum