DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 09-25-2010, 06:26 PM
hillvalley hillvalley is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2010
Age: 30
Posts: 2
Gender: Male
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
hillvalley is on a distinguished road
Default 94 5.2 oil pressure problem

I have a 94 1500 with the 5.2. the oil pressure is bouncing around on the guage. It will be fine one minute then it will drop to 0 then back up.. changed oil and filter still doing it.. Im goin to try a pressure switched and thought about dropping the pan to check the filter screen on the oil pump. any other suggestions.. thanks
Reply With Quote
Sponsored links
  #2  
Old 09-25-2010, 06:43 PM
RootBeer RootBeer is offline
Dodge Ram Forum Senior Member!

 
Join Date: Jun 2010
Location: Tucson, AZ
Age: 57
Posts: 7,181
Gender: Male
Vehicle: 2014 Ram 1500
Trim Level: Big Horn
Color: RootBeer
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 10
Rep:1287
RootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud ofRootBeer has much to be proud of
Default

I'd do the easy stuff first like the sensor/sending unit.
__________________
Brian:
"A veteran - whether active duty, retired, national guard, or reserve - is someone who, at one point in his or her life, wrote a blank check made payable to The 'United States of America', for an amount of 'up to and including my life.'"
Reply With Quote
  #3  
Old 09-25-2010, 06:52 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

I'd get a mechanical gauge and check the pressures first. If you try a switch first and it doesn't change anything, you've thrown away money and ran the engine without oil pressure yet again.
Reply With Quote
  #4  
Old 09-25-2010, 11:52 PM
Toms Blue Ram 1500's Avatar
Toms Blue Ram 1500 Toms Blue Ram 1500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2009
Location: Dundalk , Md .
Age: 50
Posts: 21,491
Gender: Male
Vehicle: '01 Ram 1500
Trim Level: Sport with Off-Road
Color: Intense Blue
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 19
Rep:1588
Toms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant futureToms Blue Ram 1500 has a brilliant future
Default

How many miles do you have on it ? Definitely take a reading first with a mechanical gauage after you take out the stock sending unit . I'm not sure if their still putting in the nylon coated timing gears anymore but if they are and you have any significant mileage on it , it may be the screen in the pump clogged up with the nylon . Seen it many times on older engines .
__________________
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:30 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum