DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 1ST Generation Dodge Ram 1993 & Older Dodge Ram Trucks > Electrical


Notices

Electrical 1st Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 11-02-2010, 09:34 PM
lt14life's Avatar
lt14life lt14life is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2010
Location: Oklahoma City.
Age: 54
Posts: 13
Gender: Male
Vehicle: 1989 Dodge Ramcharger LE-150
Color: Red & White.
Engine: 1988-1991 318ci (5.2L) LA V8 140hp
Rep Power: 0
Rep:10
lt14life is on a distinguished road
Default 1989 Ramcharger Electric Fuel Pump??

Hello all , Well I finally found a 1989 Dodge Ramcharger LE-150. 318 auto trans, 2 wheel drive for a good price that needs work. so im looking in the vehicle and I see a toggle switch on the dash panel and I ask the seller what is this for and he said that he had recently replaced the fuel pump in the tank but it would still not start so he hard wired a bypass from the battery to the fuel pump wiring and to the toggle switch and then a ground. now when you want to start the truck youve got to turn the switch on and if you forget to turn it off it will drain the battery down. im not to sure I like this so I would like to repair the problem, I dont have a service manual yet but does anybody have any ideas where I can start to troubleshoot this issue ?? Thanks for any advice.
Reply With Quote
Sponsored links
  #2  
Old 11-03-2010, 11:23 AM
jmorton84's Avatar
jmorton84 jmorton84 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Location: Valdosta, GA
Age: 30
Posts: 8
Gender: Male
Vehicle: 2006 Dodge Ram 1500 4d
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
jmorton84 is on a distinguished road
Default

first off...check the factory harness plug where it hooks to your fuel pump, see if its getting power to there. if not, try checking fuses and/or relays under the hood and under the dash and see if you have a blown fuse/relay. i would also go to your locl parts house and pick up the haynes manual for the truck. they are only 25 bucks and are a valuable resource
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 02:56 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum