DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Exterior Modifications - Body Mods - Body Kits


Notices

Custom Dodge Ram Exterior Modifications - Body Mods - Body Kits All custom mods on the outside of your Dodge Ram. Custom Dodge Ram Body Kits, Custom Paint, Grilles, Camper Tops, Bed Liners, etc.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-18-2011, 02:39 PM
madmac7227's Avatar
madmac7227 madmac7227 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2011
Location: meridian idaho
Age: 29
Posts: 1
Gender: Male
Vehicle: 2007 dodge ram megacab
Trim Level: slt
Color: white
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
madmac7227 is on a distinguished road
Default help with speedo not working

i was wiring my stereo and sparked a wire in the back now my speedo and odo do not work any ideas ?
Reply With Quote
Sponsored links
  #2  
Old 01-22-2011, 09:15 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Start simple. Check all the fuses.
Reply With Quote
  #3  
Old 01-27-2011, 02:04 PM
redhemi06's Avatar
redhemi06 redhemi06 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2011
Location: El Paso, TX
Posts: 97
Gender: Male
Vehicle: 2006 Dodge Ram
Trim Level: ST
Color: Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:36
redhemi06 is on a distinguished road
Default

did you fix this, i have the same problem and its not my fuses, looking to be like the rear speed sensor
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 11:14 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum