DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Performance Mods - Engine - 5.9 Liter V8


Notices

Custom Dodge Ram Performance Mods - Engine - 5.9 Liter V8 Discuss modifying your Dodge Ram with Performance Parts and Accessories!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 06-07-2011, 06:20 PM
BronteRider's Avatar
BronteRider BronteRider is offline
Dodge Ram Forum Junior Member
 
Join Date: Feb 2010
Location: Bronte, Tx
Age: 20
Posts: 32
Gender: Male
Vehicle: 1997 Ram 1500
Trim Level: Laramie SLT
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
BronteRider is on a distinguished road
Default Whats goin' on?

First off, my truck has been acting funny lately. I would start it and instantly have a rough, low idle with a loud sucking sound. My stepdad said it had a vacuum leak so I thought it was just getting worse and needed to be moved up on the priority list. Today while driving in san angelo, it needed more help from me keeping idle up than usual at stoplights, but I noticed a/c was on so i turned it off and kept driving, but it was still acting up. On the way home, trying to get up to 70 but the truck wouldn't. It was like bogging down and made a loud popping noise once or twice so i slowed to 60, 55, finally at 50 it stopped. 54 was the max speed, less than 1500rpm or else it would act up again. I was frustrated at this point and just hammered it with no problem. It was either very slow acceleration or wot, no inbetween. It hasnt shown the check engine light and all the fluid levels are good, so what could the problem be? Any insight would be appreciated, thank you.
Reply With Quote
Sponsored links
  #2  
Old 06-07-2011, 06:53 PM
bigblack21 bigblack21 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2011
Location: pueblo CO
Age: 20
Posts: 22
Gender: Male
Vehicle: 1999 Dodge Ram
Color: black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:46
bigblack21 is on a distinguished road
Default

i had the same idle problems during the winter. sometimes it would fire up like a chap and other times i would have to help it stay running
Reply With Quote
  #3  
Old 06-08-2011, 12:39 AM
deanthecrabman's Avatar
deanthecrabman deanthecrabman is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2009
Location: St Petersburg, FL
Posts: 948
Gender: Male
Vehicle: 2001 Ram 1500 Quad 4WD 5.9
Trim Level: Quad cab
Color: Garnet red
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 6
Rep:202
deanthecrabman has a spectacular aura aboutdeanthecrabman has a spectacular aura aboutdeanthecrabman has a spectacular aura about
Default

Check the vacuum line to the MAP sensor. It's right on the front of the TB.
Reply With Quote
  #4  
Old 06-08-2011, 08:17 PM
BronteRider's Avatar
BronteRider BronteRider is offline
Dodge Ram Forum Junior Member
 
Join Date: Feb 2010
Location: Bronte, Tx
Age: 20
Posts: 32
Gender: Male
Vehicle: 1997 Ram 1500
Trim Level: Laramie SLT
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
BronteRider is on a distinguished road
Default

Ok I had a mechanic friend come by with a code reader, and it said that is was the bank1 sensor1 O2 sensor.So where is this one?
Reply With Quote
  #5  
Old 06-09-2011, 09:08 PM
Gmcmahon4242 Gmcmahon4242 is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2011
Location: SWFL
Age: 24
Posts: 16
Gender: Male
Vehicle: 02 Ram 1500 4x4
Trim Level: Sport
Color: Black
Engine: 2002-2003 360ci (5.9L) Magnum V8 245hp 335lb/ft
Rep Power: 0
Rep:10
Gmcmahon4242 is on a distinguished road
Default

Should be driver side before the cat.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure Gauge Goin Crazy? carnage 5.9L V8 Specific Topics 18 05-31-2010 01:58 PM
Whats goin on??? 06DodgeRam 5.7L V8 Specific Topics 5 09-22-2009 12:27 PM
goin up crakr Newbie Checkin! 12 08-04-2009 05:35 PM
Blues goin away party DesertDog Off Topic Discussion 23 01-30-2009 08:44 PM


Advertisement






All times are GMT -4. The time now is 12:21 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum