DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > Cummins Diesel Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-26-2009, 01:46 PM
rcbarton70 rcbarton70 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2009
Age: 78
Posts: 3
Gender: Male
Rep Power: 0
Rep:10
rcbarton70 is on a distinguished road
Angry richard barton

Hi , I,m a newbie, i have a 1998 ram, diesel i have a problem, my speedometer just barely moves, also the abs light is on, also the brake light,, i installed a new speed sensor in the fifferential, and it still does the same thing, i would like to know what to check next, thank you
Reply With Quote
Sponsored links
  #2  
Old 03-26-2009, 01:48 PM
rcbarton70 rcbarton70 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2009
Age: 78
Posts: 3
Gender: Male
Rep Power: 0
Rep:10
rcbarton70 is on a distinguished road
Default

Quote:
Originally Posted by rcbarton70 View Post
Hi , I,m a newbie, i have a 1998 ram, diesel i have a problem, my speedometer just barely moves, also the abs light is on, also the brake light,, i installed a new speed sensor in the fifferential, and it still does the same thing, i would like to know what to check next, thank you
the truck has 175.000 miles on it,, runs great,,
Reply With Quote
  #3  
Old 03-26-2009, 01:50 PM
rcbarton70 rcbarton70 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2009
Age: 78
Posts: 3
Gender: Male
Rep Power: 0
Rep:10
rcbarton70 is on a distinguished road
Default Richard

Hi , I,m a newbie, i have a 1998 ram, diesel i have a problem, my speedometer just barely moves, also the abs light is on, also the brake light,, i installed a new speed sensor in the fifferential, and it still does the same thing, i would like to know what to check next, thank you[/QUOTE]

the truck has 175.000 miles on it,, runs great,,
Reply With Quote
  #4  
Old 03-29-2009, 09:35 AM
tom9705ram
Guest
 
Posts: n/a
Default

i had a problem before not on a dodge, it was an electrical break in a wire and the speedometer was only reading half the real time speed. make sure the connection on back of the instrument cluster is all in tact and secured properly with no breaks in wires. hope this may help out some
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:52 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum