DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-21-2011, 05:41 PM
24CTGoldie 24CTGoldie is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2011
Location: Fort Collins
Posts: 2
Gender: Male
Vehicle: 2001 Dodge Ram 1500
Color: Maroon
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
24CTGoldie is on a distinguished road
Default Speedometer & Odomoter not Working

Hi All,

I know this is a common problem, but please see my whole post.
I just bought a 2001 1500 5.9 with a check engine light on, abs light on, and the speedo and odo don't work.
However, Advanced Auto Parts said the check engine light was being thrown because of the rear speed sensor. So I replaced that. Didn't fix the check engine light. I looked around at other forums and read that you should replace the other one. So I replaced that. Now the check engine light is off, but my speedo and odo are still not working and the abs light is still on.

So, where do I go from here?
Reply With Quote
Sponsored links
  #2  
Old 08-22-2011, 11:29 AM
RAM3QRTTON4X4's Avatar
RAM3QRTTON4X4 RAM3QRTTON4X4 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2011
Location: Mundelein, IL
Posts: 12
Gender: Male
Vehicle: 1999 Dodge Ram 2500
Trim Level: Laramie
Color: Red
Engine: 1993-1993 360ci (5.9L) Magnum V8 230hp 325lb/ft
Rep Power: 0
Rep:10
RAM3QRTTON4X4 is on a distinguished road
Default

what do you mean the other one? Have you tried the speed sensor in the trans? ive replaced them on the 3rd gens (48re) but im assuming theres one on the 47re
__________________
1999 Dodge Ram 2500 Laramie SLT LD, 5.9L 4x4, ext cab, long bed. still ticking on 140k miles.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake lights not working gkconcepts Newbie Checkin! 11 07-22-2012 02:26 PM
1994 Dodge Ram 1500 Speedometer Not Working Big Blue 1500 Electrical 1 04-10-2011 03:29 AM
1998 4x4 Speedometer not working FF54 Body & Interior 15 03-06-2011 01:17 PM
Speedometer Calibration Cap10crch Electrical 7 11-14-2010 10:24 AM
speedometer not working and cruise control not working 3stepdrop 5.2L V8 Specific Topics 4 07-03-2010 10:54 AM


Advertisement






All times are GMT -4. The time now is 08:54 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum