DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 12-01-2011, 09:32 PM
black beast black beast is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2011
Location: illinois
Age: 23
Posts: 89
Gender: Male
Vehicle: 2000 dodge ram 1500
Color: black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
black beast is on a distinguished road
Default turn signal questions

when i go to use my left turn signal it flashes quickly and i checked the bulbs and fuses and they are all fine. but when i use the hazzards it works fine. any suggestions?
Reply With Quote
Sponsored links
  #2  
Old 12-02-2011, 07:30 PM
erm
Guest
 
Posts: n/a
Default

I am assuming you checked both ends of the truck?
Reply With Quote
  #3  
Old 12-02-2011, 08:22 PM
ramfam's Avatar
ramfam ramfam is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2011
Location: Missouri
Posts: 967
Gender: Male
Vehicle: 2001 1500/1982 D150
Trim Level: Base
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:21
ramfam is on a distinguished road
Default

check for a bulb shorted or relay going bad. but if its just the left only doing it take both of the left bulbs out. make sure the elements arnt touching and make sure only the bigger of the two elements light with the turn signal.
__________________
Family truck' ster see restoreation of big al's 82 http://i1152.photobucket.com/albums/p497/ramfam01/690d234c.jpg
Reply With Quote
  #4  
Old 12-02-2011, 08:31 PM
black beast black beast is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2011
Location: illinois
Age: 23
Posts: 89
Gender: Male
Vehicle: 2000 dodge ram 1500
Color: black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
black beast is on a distinguished road
Default

checked both ends and since i messed with the bulbs everything seems to be alright today. guess i wait and see. thank you i will let you know if it doesnt work
Reply With Quote
  #5  
Old 12-02-2011, 09:07 PM
Barnyard's Avatar
Barnyard Barnyard is offline
Dodge Ram Forum Senior Member!
 
Join Date: Oct 2009
Location: Katy, TX
Age: 41
Posts: 1,417
Gender: Male
Vehicle: 2011 Ram 1500
Trim Level: Sport
Color: Bright White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 5
Rep:209
Barnyard has a spectacular aura aboutBarnyard has a spectacular aura aboutBarnyard has a spectacular aura about
Default

Quote:
Originally Posted by black beast View Post
checked both ends and since i messed with the bulbs everything seems to be alright today. guess i wait and see. thank you i will let you know if it doesnt work
It might be something as simple as some corrosion in the socket then. Give them a good inspection if you have to go into them again.
__________________
Yard Fear the government that fears your gun!
Undercover Tonneau, Raptor Step Bars, Volant CAI, Cabin Air Filter Add, Debadged, 5000K HID Lows & Fogs, Custom "Hitch Cubby"
Reply With Quote
  #6  
Old 12-02-2011, 09:09 PM
ramfam's Avatar
ramfam ramfam is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2011
Location: Missouri
Posts: 967
Gender: Male
Vehicle: 2001 1500/1982 D150
Trim Level: Base
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:21
ramfam is on a distinguished road
Default

Hope all goes well.
__________________
Family truck' ster see restoreation of big al's 82 http://i1152.photobucket.com/albums/p497/ramfam01/690d234c.jpg
Reply With Quote
  #7  
Old 12-02-2011, 09:59 PM
black beast black beast is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2011
Location: illinois
Age: 23
Posts: 89
Gender: Male
Vehicle: 2000 dodge ram 1500
Color: black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
black beast is on a distinguished road
Default

well i looked at them again and it mught have been some corrosion because they work fine now. thank you guys im glad i joined this sight
Reply With Quote
  #8  
Old 12-03-2011, 07:21 PM
camoman214 camoman214 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2011
Posts: 217
Gender: Male
Vehicle: None right now
Rep Power: 0
Rep:11
camoman214 is on a distinguished road
Default

Glad they're working. I was gonna suggest that the turn signal "flasher" itself might be malfunctioning. That's happened to me before.
__________________

Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:13 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum