DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #11  
Old 10-23-2009, 05:43 PM
Sparky's Avatar
Sparky Sparky is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2009
Location: Minnesota
Age: 33
Posts: 384
Gender: Male
Vehicle: '06 Ram Quad Cab HEMI
Trim Level: SLT
Color: FLAME RED
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:23
Sparky is on a distinguished road
Default

I know when I have messed up electrical problems, most the time it is a ground problem somewhere.
Reply With Quote
  #12  
Old 10-23-2009, 07:53 PM
deanthecrabman's Avatar
deanthecrabman deanthecrabman is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2009
Location: St Petersburg, FL
Posts: 948
Gender: Male
Vehicle: 2001 Ram 1500 Quad 4WD 5.9
Trim Level: Quad cab
Color: Garnet red
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 6
Rep:202
deanthecrabman has a spectacular aura aboutdeanthecrabman has a spectacular aura aboutdeanthecrabman has a spectacular aura about
Default

Quote:
Originally Posted by Toms Blue Ram 1500 View Post
Stranger things have happened . Easy test here . You have the good bulb you took out of the left front . It is a good bulb . We know that . Plug that in the R/F and see if it works . I have seen brand new bulbs out of the box be defective . If the bulb from the L/F still doesn't work then we have a power or ground problem which you need a voltmeter . Let us know how you make out . If you still have a problem let us know and we''ll go to the next step . Tom
Gotta love the simple fixes!!
Reply With Quote
  #13  
Old 10-23-2009, 08:24 PM
CHILLZ HEMI's Avatar
CHILLZ HEMI CHILLZ HEMI is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2009
Location: Virginia Beach, VA
Posts: 879
Gender: Male
Vehicle: 2008 Dodge Ram 5.7L HEMI
Trim Level: Big Horn, Quad Cab
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:47
CHILLZ HEMI is on a distinguished road
Send a message via AIM to CHILLZ HEMI
Default

And you had a mechanic look over the whole wiring harness that is part of the headlights, and turn signals??? And all the wires were good???
__________________
Reply With Quote
  #14  
Old 11-20-2009, 09:31 AM
Jasser's Avatar
Jasser Jasser is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2009
Location: Ontario Canada
Posts: 12
Gender: Male
Vehicle: 2006 Dodge RAM 1500 4x4
Trim Level: Sport
Color: Mineral Gray
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Jasser is on a distinguished road
Default

OK... Found the issue with the Passenger Low Beam not working.

My Mechanic looked it over with this new tester he got.

Bulb is good, wire is good, all fuses are good.

The problem? The "Totally Integrated Power Module". Part's price is at $689 canadian. He can get one for me at cost for $599. Either way, not cheap!

Why the heck would one of these fail? this truck's 3 years old!

Anybody else had issues with this thing? Anyone hear of recalls on this part?

Fack....
Reply With Quote
  #15  
Old 01-08-2010, 08:48 PM
leroycool1 leroycool1 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Age: 32
Posts: 1
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
leroycool1 is on a distinguished road
Default

hi

i am new here

i came on here looking for info on this same problem

a guy at work has that same problem its a 2007 1500 with a hemi it started about a month ago and he has not done anything about it yet

and today my dad said he had the same problem on a 2007 3500 cummins i dont think i want to tell him the problem is $600 + to fix

i hope mine does not do this HAHA its a 2007 1500 hemi
Reply With Quote
  #16  
Old 01-09-2012, 09:30 PM
powers07ram powers07ram is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2012
Location: va
Age: 27
Posts: 3
Gender: Male
Vehicle: 2007 dodge ram 1500
Trim Level: sly thunder road
Color: blue
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
powers07ram is on a distinguished road
Default

i am having kinda the same problem but my left side low beam is out and everything else works fine l and r high beam and r low beam works fine
Reply With Quote
  #17  
Old 02-01-2012, 11:32 AM
h2oman226 h2oman226 is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2012
Location: Hastings, Michigan
Age: 41
Posts: 1
Gender: Male
Vehicle: 2006 Dodge Power Wagon
Color: Silver
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
h2oman226 is on a distinguished road
Default

i replaced my TIP years ago, prob around 2009 when my truck was 3 yrs old. Back then, it was causing all sorts of mysterious gremlins, but none effecting the headlights.

So fast forward 3 years to present day, Now my drivers headlight functions in dim, but not bright. The passenger side works as designed.
I've replaced the bulb, checked the harness, and did not see any blown fuses.

For about 6 months, the bright drivers light would intermittently come on/off as i drove down the road. Random, didn't seem to be effected by weather, road bumps etc. Now, no bright at all on that side.

Related, I have a Western Ultramount plow setup i use on this rig. Sure enough, i've hooked it up, and i have no bright on the drivers plow light either, which is all wired into the main box under the hood.

If the TPI has gone bad again, i'm going to flip. i may just consider jumping the lead from the passenger side over to the drivers side to save myself the $800.

Any tips?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 04:34 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum