DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-01-2012, 04:04 PM
sunmicroman sunmicroman is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2012
Posts: 1
Gender: Male
Vehicle: 1997 Dodge Ram 2500 4x4
Rep Power: 0
Rep:10
sunmicroman is on a distinguished road
Default Engine Temp and 4WD Dash Light

Just bought a '97 Ram 2500 4x4 with 122k on it. Just had a few questions, though. One is, the coolant temp on the dash seems to fluctuate between 180-200F when driving the truck. Is this normal? If I am at a stop for a while it goes up to just about the middle mark (200) and then when I start moving it almost immediately goes back down to about 180 or so. I also noticed the coolant reseviour tank is empty. But I see no noticeable leaks anywhere.

Second is the 4WD light on the dash seems to flicker on and off. I tested the 4WD when I bought the truck and it worked fine and seemed to shift between 2WD and 4WD fine, it's just the dash light likes to flicker here and there. Is this just possibly a switch or sensor needing adjustment?

Thanks in advance for your help. So far, I really like this truck.
Reply With Quote
Sponsored links
  #2  
Old 02-02-2012, 11:45 PM
Screamintrashcan Screamintrashcan is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2011
Location: Alston, MI (BRRrrr)The shores of Gitche Gume
Age: 56
Posts: 456
Gender: Male
Vehicle: 95 & 98 1500 Ram 4x4s
Trim Level: SLT & Sport
Color: 1 Blk,1 Red
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:36
Screamintrashcan is on a distinguished road
Default

Both of my trucks are pretty 'coolant level sensitive', and if low at ALL, they send cold air out of the heat ducts, and the gauge wanders. This is even if they're only a cup or so low in the radiator. If the radiator is low, the expansion tank is probably going to drink up a half gallon. Now the 4x4 light. Hmm, thats a new one for me, never heard of an intermittant lite... I'd probably go to the axle disconnect, and pull the plug and look at the pins, etc to see if they're corroded, for starters... My 95s light for 4x4 has never worked, (only recently discovered that it has one!!) I know the 96 has the same light, I don't know about the 97s, my 98 is all different on the instrument cluster, and it's always worked great, except when one of the vacuums tube fell off, on the left side of the crossmember, and the light didn't work, but neither did the axle disconnect. (so it isn't the vacuum tube disconnected on yours)
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 03:32 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum