DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Notices


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Total Load Control!
Mopar Online Parts!
MOPAR DECALS
FGT Motorsport
Addictive Desert Designs!
FGT Motorsport
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-14-2012, 10:09 PM
geemc69 geemc69 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: birmingham alabama
Age: 47
Posts: 3
Gender: Male
Vehicle: 2002 ram 1500 4.7
Trim Level: slt qaud cab
Color: red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
geemc69 is on a distinguished road
Angry p1391 code keeps coming up

hello all , i have a 2002 ram 1500 4.7 i keep getting a p1391 code which is intermittent loss of crank and cam sensors i have changed both of those sensors including the tps and still the code comes right back the motor jumps and lunges like crazy then shuts down i was told that my problem was the fact that i used parts from autozone so i took them all back and got all new from dealer and it runs worst than with the ones from autozone so now i'm at my wits end i'm kinda guessing its the pcm but i would like to know for sure before i get a new one....please help
Reply With Quote
Sponsored links
  #2  
Old 03-17-2012, 05:29 PM
THK THK is offline
Dodge Ram Forum Member

 
Join Date: Jun 2011
Location: Out West
Posts: 65
Gender: Male
Vehicle: 02 Dodge Ram
Trim Level: ST
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
THK is on a distinguished road
Default

The code will tell you whats happening and get you to the general area. It's your job to diagnosis the cause of the problem. Since you replaced the sensors (oh, by the way, auto zone, o'rileys, napa, usually sell name brand sensors like ngk, bosch, delphi. Chrysler gets their sensors from one of these guys.

Start checking connectors for corrision, loose connections, ohm check the wires for interanal breaks (the jiggle test). If you relaced the sensors and the same problem, not the sensors.
Reply With Quote
  #3  
Old 03-27-2012, 07:12 PM
geemc69 geemc69 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: birmingham alabama
Age: 47
Posts: 3
Gender: Male
Vehicle: 2002 ram 1500 4.7
Trim Level: slt qaud cab
Color: red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
geemc69 is on a distinguished road
Default

well i have changed all of my sensors and changed my pcm and still the same code and same problem i checked all the connectors and cant seem to find anything wrong with them i took off the iac and it was really dirty so i took off the throttle body and its soaking right now so i will just have to wait till tomorrow to see what its gonna do i am at a total lost and i have spent out alot of money so far does anyone have a similar problem or experienced the same please help
Reply With Quote
  #4  
Old 03-30-2012, 12:17 AM
geemc69 geemc69 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: birmingham alabama
Age: 47
Posts: 3
Gender: Male
Vehicle: 2002 ram 1500 4.7
Trim Level: slt qaud cab
Color: red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
geemc69 is on a distinguished road
Default

well i wasted money on the pcm it didnt fix my problem but today i went into the motor and found my problem my timing chain tensioner guide was broke i had just replaced all of the guides and chains about 3 months ago only to find out that the warranty is only good for 3 months so i bought replacements with gears this time hope this helps anyone else with the same problem
Reply With Quote
  #5  
Old 06-25-2016, 07:10 PM
rambo90167 rambo90167 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2016
Location: new hampshire
Age: 49
Posts: 15
Gender: Male
Vehicle: 1996 dodge 1500
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
rambo90167 is on a distinguished road
Default

mine did that changed all the sensors didn't help found the alternator voltage too low changed it runs like new now
Reply With Quote
  #6  
Old 06-25-2016, 09:56 PM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Senior Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 26,438
Gender: Male
Vehicle: 2016 Ram Ecodiesel 2 whl drive
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 26
Rep:2875
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

explanation about examining-crank-cam-sensor-errors-and-their-diagnoses

http://www.searchautoparts.com/motor...heir-diagnoses

sounds like a 12 volt Oscilloscope would come in handy, if a person knows how to read it
__________________
2016 Ram 3.0 diesel 3.55 w/LSD, G2 tonneau, Line-X, Weathertech mats, Mag-Hytec differential cover, Nfab bars, CB radio, Autonet wi-fi router, EGR bug deflector
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement








All times are GMT -4. The time now is 05:35 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors