DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-17-2012, 02:44 PM
brokedodge brokedodge is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Age: 47
Posts: 2
Gender: Male
Vehicle: 98 ram
Rep Power: 0
Rep:10
brokedodge is on a distinguished road
Default No Start

98 5.2 has no start

Took off alt cable to get to CTS plug, cable touched ground

Now no start

repl crank sensor, coil pck up, ECM was replaced and flashed, tried the ign on/off X2 and cel does not blink

HELP PLEASE dunno what to check and or replace
Reply With Quote
Sponsored links
  #2  
Old 07-17-2012, 02:53 PM
RcsbHemi's Avatar
RcsbHemi RcsbHemi is offline
Dodge Ram Forum Senior Member
 
Join Date: May 2010
Location: NY
Age: 32
Posts: 193
Gender: Male
Vehicle: 2010 Ram Rcsb
Trim Level: SLT 4x4 3.92
Color: PDM Metallic Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:32
RcsbHemi is on a distinguished road
Default

Check for a burnt fusible link, also check all fuses.
__________________

Mods: Magnaflow DOD14(resonator removed) line-x, tint, silverstars, tonno pro trifold tonneau, LED Licence plate and reverse bulbs, 2- 27w led fog lights behind grille. more to come........
Reply With Quote
  #3  
Old 07-17-2012, 05:43 PM
brokedodge brokedodge is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Age: 47
Posts: 2
Gender: Male
Vehicle: 98 ram
Rep Power: 0
Rep:10
brokedodge is on a distinguished road
Default

No fusible link visible, can you give me some clue to where it is located?
Thanks
Reply With Quote
  #4  
Old 07-18-2012, 12:57 AM
RcsbHemi's Avatar
RcsbHemi RcsbHemi is offline
Dodge Ram Forum Senior Member
 
Join Date: May 2010
Location: NY
Age: 32
Posts: 193
Gender: Male
Vehicle: 2010 Ram Rcsb
Trim Level: SLT 4x4 3.92
Color: PDM Metallic Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:32
RcsbHemi is on a distinguished road
Default

The fusible like is in line with the cable that you grounded. That likely caused it to burn out, follow the cable from the alternator to the other end and there should be a bulge in the wire(that is the link). Disconnect it from the alternator and at the other end and check for continuity. If it is burnt you may need to replace the cable. Good luck.
__________________

Mods: Magnaflow DOD14(resonator removed) line-x, tint, silverstars, tonno pro trifold tonneau, LED Licence plate and reverse bulbs, 2- 27w led fog lights behind grille. more to come........
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:02 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors