DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 09-27-2012, 01:00 PM
Talltwisted1
Guest
 
Posts: n/a
Default 5.2 to 5.9 Swap Headaches

So. a tired non running 5.2 came out. A low mileage 5.9 went in. starts and running great. for 10 to 15 minutes once everything comes up to temp, maybe when it goes to closed loop, the engine falls on it face and runs horribly and misfires. Several computers, and several idead, including catalytic converter which is now off. Seriously need help. runs great cold, just horrible after.
Reply With Quote
Sponsored links
  #2  
Old 09-27-2012, 03:42 PM
Maddevill Maddevill is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2010
Age: 56
Posts: 553
Gender: Male
Vehicle: 2003 Dodge Ram 1500 Quad
Trim Level: SLT
Color: Grey
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:27
Maddevill is on a distinguished road
Red face Maybe this

It could be that the Inlet Air Temp sensor or the coolant temp sensor is bad. It could be causing the computer to think that the engine is always cold, enriching the mixture. This would explain why it runs good cold but bad hot.
Reply With Quote
  #3  
Old 09-27-2012, 03:49 PM
GTyankee's Avatar
GTyankee GTyankee is online now
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 18,837
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 19
Rep:2615
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

Did you use all the sensors & connections from the 5.2 ? are you trying to use those parts off the 5.9 ?

Is the computer that you are using from the 5.2 or the 5.9 ?
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
  #4  
Old 09-27-2012, 03:59 PM
Talltwisted1
Guest
 
Posts: n/a
Default

air inlet temp sensor sounds promising used everything off of the 5.9 but all the wiring from the 5.2 computer has been changed a few times but finally got ahold of the original computer im going to try that computers form the 5.2 and 5.9 should work either way ive been told but the ecu is flashed with the vin and trim so im hoping the original computer may fix some of the issues
Reply With Quote
  #5  
Old 09-27-2012, 11:23 PM
Talltwisted1
Guest
 
Posts: n/a
Default

so update put in original computer i think runs awesome for 15 minutes after start up then starts to make a small misfire sound then progressively get worse over 3 to 5minutes until idle and acceleration go to crap shut down start right back up still the same only good when its cold
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:07 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum