LED Turn Signal Problem!.. - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 10-04-2012, 01:53 AM
codeman004 codeman004 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2012
Age: 25
Posts: 4
Gender: Male
Vehicle: 2001 Dodge Ram
Color: Red
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
codeman004 is on a distinguished road
Default LED Turn Signal Problem!..

Hey everyone, i need some help. i own a 2001 Dodge Ram Sport and i recently installed LED turn signals that match the correct bulbs. After i did this, my turn signals flash a lot quicker throughout the whole system (front, back, inside). My 4-ways (hazard lights) work normally, just my turning signals are hyper-flashing. What can i do to fix this??

-Cody
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-04-2012, 01:55 AM
ShawnC13's Avatar
ShawnC13 ShawnC13 is offline
Cheap Canadian Labour




 
Join Date: Dec 2011
Location: Victoria BC Canada
Age: 44
Posts: 41,871
Gender: Male
Vehicle: 2008 Dodge Ram 1500 QC TRX4
Trim Level: SXT
Color: Flame Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 31
Rep:2071
ShawnC13 has a reputation beyond reputeShawnC13 has a reputation beyond reputeShawnC13 has a reputation beyond reputeShawnC13 has a reputation beyond reputeShawnC13 has a reputation beyond reputeShawnC13 has a reputation beyond reputeShawnC13 has a reputation beyond reputeShawnC13 has a reputation beyond reputeShawnC13 has a reputation beyond reputeShawnC13 has a reputation beyond reputeShawnC13 has a reputation beyond repute
Default

Did you add a resistor in line? The led's are a lower load or draw and you need more resistance when you use led to take care of the hyper flash issue. In my signature is a link to my tails and turn signals take a look there and see what I am talking about
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 05:54 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright © VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors