DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 09-26-2012, 11:50 PM
txdixiebelle txdixiebelle is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2012
Location: Texas
Age: 35
Posts: 2
Gender: Female
Vehicle: 2005 Dodge Ram 1500
Trim Level: qual cab
Color: Red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
txdixiebelle is on a distinguished road
Unhappy High and Low beam problems

I have a 2005 Dodge Ram 1500, and I'm having problems with the high and low beams headlights. On the driver side the low beam doesn't work, but the high beam works. Now on the passenger side it's just the opposite the high beam doesn't work but the low beam does. I've already replaced the headlights on both sides What could be causing this, and what am I'm going to have to replace. Please if anyone knows please respond to this cause I'm going out of my mind trying to figure out is going on with my truck. And please let me know how much this is going to cost me to get fixed.
Reply With Quote
Sponsored links
  #2  
Old 10-08-2012, 01:38 AM
astevenson astevenson is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2012
Location: blue springs MO
Age: 35
Posts: 14
Gender: Male
Vehicle: 2008 dodge ram mega cab
Trim Level: slt
Color: white
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
astevenson is on a distinguished road
Default

My boss had that problem with his 04 at least the low beam not working. took it to the dealer they told him there was some kinda control module I beleive that was bad. It has one for each head light. They wanted a few hundred dollars to fix it.
Reply With Quote
  #3  
Old 11-08-2012, 04:30 AM
RamSport1500's Avatar
RamSport1500 RamSport1500 is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2012
Location: Maine
Age: 30
Posts: 32
Gender: Male
Vehicle: 2006 Dodge Ram
Trim Level: Sport
Color: Slate
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
RamSport1500 is on a distinguished road
Default

I have a 06 Ram Sport 1500 5.7 Quad cab... my right low beam went... Did somee research through here a lot of guys are having problems with that same issue. Its the TIPM (Total Intergrated Power Module) Dodge basically wired everything through it... When it starts going it does that. Commonly its the right passanger low beam that goes.... Had my personal Mechanic check the truck confirmed it. I dont rust a Dodge mechanic... they like sales men they say almost anything amd change you hundreds to fix it and still be wrong. Once I confirmed it was the TIPM I had to go to a Dodge dealer cause appearently you have to get the part from Dodge and Dodge as my mechanic told me has a monoply on the flash codes so outside sources cant get it. Unless you have a buddy that can hook you up at a Dodge dealer its going to be pricey fix... I spent just under $700 to fix it... and at the time i had only had the truck months from date of purchase. After it was replaced I noticed my trucks features working like the radio staying on with Ignition off after they key is out until you open the door. Im now having issues with my Instrument cluster... Tach reading 500 RPM at 70 mph on the highway and 0 at a idle... The dodge dealer originally said the lights and the cluster were the cause of the TIPM but the replacement only fixed the head light and some of the features... my cluster is still all jacked upand now they are saying its a seperate issue but want to run more "test" to confirm it...
Reply With Quote
  #4  
Old 11-08-2012, 08:48 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 43
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Quote:
Originally Posted by RamSport1500 View Post
I have a 06 Ram Sport 1500 5.7 Quad cab... my right low beam went... Did somee research through here a lot of guys are having problems with that same issue. Its the TIPM (Total Intergrated Power Module) Dodge basically wired everything through it... When it starts going it does that. Commonly its the right passanger low beam that goes.... Had my personal Mechanic check the truck confirmed it. I dont rust a Dodge mechanic... they like sales men they say almost anything amd change you hundreds to fix it and still be wrong. Once I confirmed it was the TIPM I had to go to a Dodge dealer cause appearently you have to get the part from Dodge and Dodge as my mechanic told me has a monoply on the flash codes so outside sources cant get it. Unless you have a buddy that can hook you up at a Dodge dealer its going to be pricey fix... I spent just under $700 to fix it... and at the time i had only had the truck months from date of purchase. After it was replaced I noticed my trucks features working like the radio staying on with Ignition off after they key is out until you open the door. Im now having issues with my Instrument cluster... Tach reading 500 RPM at 70 mph on the highway and 0 at a idle... The dodge dealer originally said the lights and the cluster were the cause of the TIPM but the replacement only fixed the head light and some of the features... my cluster is still all jacked upand now they are saying its a seperate issue but want to run more "test" to confirm it...

I'd love to offer some advice and opinion or two, but I'm a Dodge mechanic and obviously untrustworthy. BTW, we don't have the "monopoly" on flashes. Properly equipped independent shops can do them as well. Best of luck to you with your problem.
Reply With Quote
  #5  
Old 12-20-2012, 10:15 PM
txdixiebelle txdixiebelle is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2012
Location: Texas
Age: 35
Posts: 2
Gender: Female
Vehicle: 2005 Dodge Ram 1500
Trim Level: qual cab
Color: Red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
txdixiebelle is on a distinguished road
Unhappy Headlight Problems

I'm at my wits end and need some help with trying to figure out what is going on with my headlights........... My low beam is out on my driver side, and now my high beam is out on my passenger side. I don't know what to do..... I keep getting the run around..... I need this fix cause this is the only means of transportion I have, and I work in the medical field and need my vehicle. I live in Texas near Oklahoma border... If anyone knows a place that I can take my truck to have it looked at and it not cost me an arm and leg cause I don't make that much money.
Reply With Quote
  #6  
Old 01-06-2013, 05:51 PM
mopars and mountains mopars and mountains is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: langley bc/edmonton alberta
Posts: 2
Gender: Male
Vehicle: 2007 ram
Trim Level: laramie
Color: gray
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
mopars and mountains is on a distinguished road
Default day time running lights and high beams all out

so ive resently moved out of bc to alberta and am in need of a veicle inspection and as the hids blueish light temp color is frouned apon to pass ive had to uninstall a custom hid and led set up and am now running the stock bulbs. now the drl and high beams are not working, ive sourced that the drl's are run by the high beam output so perhapts my high beams are malfunctioning and in turn drl's not working. wile all along all other lights; tail marker low beam and fog function normally. please help i need some direction badly i really dont want to spend a thousand to fix this. thanks

Last edited by mopars and mountains; 01-06-2013 at 05:55 PM.
Reply With Quote
  #7  
Old 01-15-2013, 02:31 PM
simonmw75 simonmw75 is offline
Dodge Ram Forum Junior Member
 
Join Date: Aug 2011
Location: Maryland
Age: 39
Posts: 39
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Sport
Color: Graphite
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:72
simonmw75 will become famous soon enough
Default

I had a similar issue with my 02. My headlights just quit working. Like most of us, i hit the forumz for similar issues. Long story short, it turned out to be corrosion inside the fuse box assembly under the hood. Seems that either thru bad design or whatever, water found its way onto the printed circuit board and caused enough corrosion of the wire closest to the edge of the board. Turns out that was the wire for the headlights. Cost for a new circuit board would have been $700. Cost for the shop to replace it would have brought it up to around $1000. F that.

What i did, and what led to my discovery, was the complete disassembly of the fuse box. That means removing it from the vehicle, and taking note of where each fuse goes, cuz i had to pull them all out. Once i got to that circuit board, i could see the delamination of the board and what wire to test. To fix the wire, i used a wire brush to clean and remove corrosion, then used a solder gun to reconnect it. Or i could have ran a new wire. It may seem odd to use a wire brush to clean a wire, but remember, it is running through the layers of the board, not open and surrounded by plastic. My multimeter also helped me troubleshoot.

Hope this helps
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 11:17 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum