DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Heating & Cooling


Notices

Heating & Cooling 2nd Gen Dodge Ram Heating & Cooling Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-25-2013, 03:19 PM
JamelG86 JamelG86 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2012
Posts: 1
Gender: Male
Vehicle: 2000 Dodge Ram 1500
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
JamelG86 is on a distinguished road
Default 2000 Ram 1500 5.2L - Heat Problems? Try This...

Now this is no permenant fix, nor do I even know why it works the way it works...

I have done two back flushes to my heater core.. Inspected every motor actuactor is working. My heater core melts my finger prints off... Upper rad hose is hot, lower is pretty cold (could be bad circulation from a water pump?)

I have bled and bled and bleddddd the system for DAYS! OK DAYS! I've gone nuts doing it.

So what's this temp fix?

I noticed that when I put my control to MAX A/C (my a/c isn't working don't know why bought this 1.5 months ago now) my heat will build up getting hotter and hotter.

If you drop the glove box you will see a door being shut towards the front of the engine, I believe it's the recirc door... When you put it on any other mode at least on my truck it opens the recirc door completely bringing it towards you. Giving me next to no heat...

So I wedged something in there for the time being to stop the door from closing fully but just open a bit of course for anti fog.

I hope to fix this problem without throwing parts at it. I started having no heat after I did my thermostat..? This was months ago and 3 thermostats later...

I think it's a vacuum related issue... Possibly a bad switch sending wrong recirc door signal?

At least it hasn't blown up yet like my ford 4.6 did
Reply With Quote
Sponsored links
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:24 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum