DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-30-2014, 08:17 PM
Ramsky65 Ramsky65 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2014
Location: bc
Posts: 4
Gender: Male
Vehicle: 2005 Doge Ram
Trim Level: SLT
Color: gray
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Ramsky65 is on a distinguished road
Default Hi, am a newbie and need help: PO132

Hi,

I am asking for help again, think I muffed the first attempt. My 2005 Ram 1500-5.7 (43,000 mi.) is hesitating a bit on acceleration, I had an initial P0300/random misfire, replaced EGR valve, code cleared, then got a PO132/front O2 sensor, replaced it, truck ran good for a few miles then PO132 again along with the acceleration hesitation and higher than normal gas consumption . Thanks for all the warm welcomes received.
Reply With Quote
Sponsored links
  #2  
Old 02-02-2014, 12:07 PM
wpattie wpattie is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2013
Location: Stonewall, Manitoba Canada
Age: 30
Posts: 26
Gender: Male
Vehicle: 2004 Dodge Ram 1500
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:72
wpattie will become famous soon enough
Default

Mine is doing this right now. I replaced all my O2 Sensors and maybe 10 miles later I start get codes for front and back O2s, replaced them and again with in 10 miles codes for both front and back. I have no clue. I clear it em every now and again with my tuner.

Last edited by wpattie; 02-02-2014 at 12:12 PM.
Reply With Quote
  #3  
Old 05-15-2014, 07:47 PM
doctorg doctorg is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Location: canada
Posts: 10
Gender: Male
Vehicle: 2001 Dodge Ram
Color: burgendy
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
doctorg is on a distinguished road
Default Po132 question.

I also had the code po132 return after a new upstream o2 sensor replacement, and am thinking I have either a bad replacement sensor or a blocked exhaust at the converter. I am now leaning toward the plugged exhaust .
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 04:55 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum