DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Heating & Cooling


Notices

Heating & Cooling 3rd Gen Dodge Ram Heating & Cooling Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-18-2014, 03:18 AM
Texas Boy Texas Boy is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2014
Location: Corpus Christi Texas
Age: 35
Posts: 4
Gender: Male
Vehicle: 2004 Dodge ram 1500
Trim Level: 4x4
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Texas Boy is on a distinguished road
Default New to forum and need help

Hi, I have a 2004 1500 4.7 4x4. Engine light came on and ac condenser fan will not turn off. Even with the truck turned off and key out of the ignition the fan continues to run. Only when I pull the relay it turns off. As soon as I plug it back in it turns on. Tried swapping relays, turning knobs, pushing as button on dash on and off with no joy. The darn thing just runs no matter what. Can any one help me with this?
Reply With Quote
Sponsored links
  #2  
Old 03-18-2014, 02:14 PM
hydrex's Avatar
hydrex hydrex is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2009
Location: Penobscot, Maine
Age: 63
Posts: 2,176
Gender: Male
Vehicle: 2005 QC 4X4 HEMI RAM
Trim Level: Thunder Road
Color: Mineral Grey
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 7
Rep:418
hydrex is just really nicehydrex is just really nicehydrex is just really nicehydrex is just really nicehydrex is just really nice
Default

First, get that code read for check engine light, might shed some light on things. Can't help you with AC, but I'd sure like to be able to use mine. Global Warming ain't hitting very hard up here in Maine. Around 0F this morning.
__________________
Inertia Spartan Plus cam, Circle D 3,000 rpm stall converter,Sonnax line pressure booster, Vararam, JBA's with cut outs, Rancho 9000's,3:92's, extra rear leaf.Line-X Bedliner, 210,000 miles To Hell and back. 14.2/96 mph NEDW
Reply With Quote
  #3  
Old 03-18-2014, 05:11 PM
Gen1dak Gen1dak is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2011
Location: MS Gulf Coast
Posts: 1,596
Gender: Male
Vehicle: 1990 RamCharger
Color: Red
Engine: 1988-1991 318ci (5.2L) LA V8 140hp
Rep Power: 4
Rep:85
Gen1dak will become famous soon enough
Default

Had that problem with my '89 Shelby Dakota, but it was a fused relay. Since you've switched them, I'd say, if it's anything like my PT Cruiser, it has two fan relays, one hi-speed, one low-speed. One is in the usual spot, the other is in a separate box. Might look into that possibility. Otherwise, consider your AC coolant level. If you have leaked coolant, the fan may run non-stop as a result. Also, don't forget to do a computer reset (with external reader or battery disconnect). That may be an issue. Sorry, no definite answers. Haven't had this issue much and relay fixed mine.
Reply With Quote
  #4  
Old 03-18-2014, 05:51 PM
Texas Boy Texas Boy is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2014
Location: Corpus Christi Texas
Age: 35
Posts: 4
Gender: Male
Vehicle: 2004 Dodge ram 1500
Trim Level: 4x4
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Texas Boy is on a distinguished road
Default condenser fan

Thanks for the advice guys. Got code P0480, coolant level is good, ac works normal with the fan relay in the fuse box. Gonna look into if there's another relay in system or maybe a temp sensor for condenser or something. Gotta do more research. I will post the fix if I ever find the problem.
Reply With Quote
  #5  
Old 03-18-2014, 09:48 PM
Texas Boy Texas Boy is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2014
Location: Corpus Christi Texas
Age: 35
Posts: 4
Gender: Male
Vehicle: 2004 Dodge ram 1500
Trim Level: 4x4
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Texas Boy is on a distinguished road
Default condenser fan continuesly runs

Found the problem. I had some green corrosion built up on a connector going to the PCM under the hood. I was unplugging all the connections and cleaning them with electro wash and found it. Working fine now.
Reply With Quote
  #6  
Old 03-18-2014, 10:27 PM
Simple guy Simple guy is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2013
Location: Pottstown, Pa
Age: 27
Posts: 247
Gender: Male
Vehicle: 2003 Ram 1500
Trim Level: SLT QC 4x4
Color: Mineral grey
Engine: 2002-2003 360ci (5.9L) Magnum V8 245hp 335lb/ft
Rep Power: 2
Rep:109
Simple guy will become famous soon enoughSimple guy will become famous soon enough
Default

interesting, the corrosion must have created a short to ground for the control wire.
__________________

Last edited by Simple guy; 03-18-2014 at 10:41 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:47 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum