DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Performance Mods - Engine - 4.7 Liter V8


Notices

Custom Dodge Ram Performance Mods - Engine - 4.7 Liter V8 Discuss modifying your Dodge Ram with Performance Parts and Accessories!
Factory Spec: 4.7-liter V8 engine - 310 horsepower, 330 lb-ft of torque.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-01-2012, 04:53 PM
CamoBoy34 CamoBoy34 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2010
Location: Hoisington,KS
Age: 21
Posts: 114
Gender: Male
Vehicle: 2004.5 Dodge Ram 2500
Trim Level: SLT
Color: White
Engine: 2005-20?? 359ci (5.9L) Cummins ISB 610 24-Valve Diesel I6 325hp 610 lb/ft
Rep Power: 0
Rep:12
CamoBoy34 is on a distinguished road
Default Need help fast!!

i have an 05 4.7L i just replaced both head gaskets on it and when i put it all back together in ran fine. it started right up the first couple turns and idled just fine and it reved through the rpms fine too. as i went to go drive it i didnt get a 1/2 mile from the farm and it wouldnt go above 2000 rpms and then it just died. it would crank but it wont start. we pulled it back and i looked on my programmer and it said i had a crankshaft position sensor code and a camshaft position code. i changed the crankshaft sensor with no luck. i cleared the codes and now they wont come back it is just saying that i have an EGR code but i had that before and it run just fine. after trying to start it over and over i have found out that if i hold the gas pedal to the floor it will spit and sputter but ONLY on cylinders 2-4-6-8 it wont fire on the left side of the motor. i know this from my programmer i have a page that counts the missfires on each cylinder and the left side wont fire. i have already pulled the valve covers and the cams are still timed right it didnt jump timing. i am also getting fuel to the motor so that isnt a problem. i have just run out of ideas and i need this truck ASAP if you know what i could do to pin point the problem id appriciate it or know of anything else i could do

thanks
Reply With Quote
Sponsored links
  #2  
Old 01-01-2012, 09:55 PM
CdnoilRAM's Avatar
CdnoilRAM CdnoilRAM is offline
I push the skinny pedal


 
Join Date: Jul 2009
Location: Calgary, AB, CA
Age: 30
Posts: 16,963
Gender: Male
Vehicle: 2009 Blown 349 Hemi
Trim Level: Sport - Modified
Color: Brilliant Black/Snake Skin Green
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 20
Rep:3225
CdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond repute
Default

Pull the valve cover and make sure there's nothing interfering with the valves or rocker arms. It's been known that people havn't put the pushrods back properly, and it's caused major issues.
__________________
Sponsored by Bully's Performance
Green Mamba '09 Ram 1500 QCRB 4x4 Sport - dropped, blown, and bottle fed
Kurtis
Reply With Quote
  #3  
Old 01-01-2012, 10:25 PM
moparist moparist is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2011
Location: Los Fresnos, Tx
Posts: 9
Gender: Male
Vehicle: 2002 dodge ram
Trim Level: 1500 short bed s.c.
Color: red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
moparist is on a distinguished road
Default

it may be a loose wire connection or harness that sends signal to spark plugs coils
Reply With Quote
  #4  
Old 01-01-2012, 11:08 PM
IN2H2O's Avatar
IN2H2O IN2H2O is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: North Charleston, SC
Age: 40
Posts: 227
Gender: Male
Vehicle: 2003 Dodge Ram 1500
Trim Level: ST
Color: Red
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 0
Rep:73
IN2H2O will become famous soon enough
Default

Crank it over with the valve covers off and watch to see if the cam is rotating on the side that isn't firing.
Reply With Quote
  #5  
Old 01-02-2012, 10:27 AM
CamoBoy34 CamoBoy34 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2010
Location: Hoisington,KS
Age: 21
Posts: 114
Gender: Male
Vehicle: 2004.5 Dodge Ram 2500
Trim Level: SLT
Color: White
Engine: 2005-20?? 359ci (5.9L) Cummins ISB 610 24-Valve Diesel I6 325hp 610 lb/ft
Rep Power: 0
Rep:12
CamoBoy34 is on a distinguished road
Default

Im pretty sure the cam is turning because I turned the motor to tdc and the cams are still in time bit I will double check after work tonight
Reply With Quote
  #6  
Old 01-02-2012, 11:42 AM
IN2H2O's Avatar
IN2H2O IN2H2O is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: North Charleston, SC
Age: 40
Posts: 227
Gender: Male
Vehicle: 2003 Dodge Ram 1500
Trim Level: ST
Color: Red
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 0
Rep:73
IN2H2O will become famous soon enough
Default

I was thinking that the bolt could have broke free and the gear is possibly just spinning without turning the cam. The sproket will still be turning and appear to be in time.

Air, fuel, spark and compression.

Fuel rail is common, if you have it on one side, you have it on both.
Air intake is common and so is ignition control. if you have one whole bank that is not firing, then the only thing left is the cam...
Reply With Quote
  #7  
Old 01-02-2012, 12:22 PM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

Check the connectors on the PCM. During the head gasket replacement, it is possible one may have come slightly dislodged. Pay particular attention to the Orange connector (C2).
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #8  
Old 01-02-2012, 09:28 PM
CamoBoy34 CamoBoy34 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2010
Location: Hoisington,KS
Age: 21
Posts: 114
Gender: Male
Vehicle: 2004.5 Dodge Ram 2500
Trim Level: SLT
Color: White
Engine: 2005-20?? 359ci (5.9L) Cummins ISB 610 24-Valve Diesel I6 325hp 610 lb/ft
Rep Power: 0
Rep:12
CamoBoy34 is on a distinguished road
Default

ok i changed the camshaft sensor and checked all the connectors they are all plugged in good. still no luck i will be getting a new EGR valve tomorrow and will put it in after work and give that a try if not i will take the valve covers off again and double check the timing
Reply With Quote
  #9  
Old 01-04-2012, 12:09 AM
CamoBoy34 CamoBoy34 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2010
Location: Hoisington,KS
Age: 21
Posts: 114
Gender: Male
Vehicle: 2004.5 Dodge Ram 2500
Trim Level: SLT
Color: White
Engine: 2005-20?? 359ci (5.9L) Cummins ISB 610 24-Valve Diesel I6 325hp 610 lb/ft
Rep Power: 0
Rep:12
CamoBoy34 is on a distinguished road
Default

Update on the truck. I'm getting spark and fuel to all cylinders. The left side is now firing and all connections are good. If I hold the gas pedal to the floor and keep it there the truck will "start" and I have to keep the pedal on the floor. The trucks rpms are so low it sounds like a Harley idling then it will backfire and die. It only runs for about 10 seconds at a time. Plus I also have a new code its a P2314 ignition coil E I have no idea what it is any help?
Reply With Quote
  #10  
Old 01-04-2012, 02:21 AM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

P2314 is complaining about 1 of the coils. I'd ignore it until the truck is running. It could be a false reading under the circumstances.

Am I reading this right? You have to hold the pedal to the floor even after it starts? And it still runs at a very low RPM?

By chance, did you verify that the crank/cam timing is still correct?
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:39 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum