DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > Cummins Diesel Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-02-2010, 05:30 PM
kstroud kstroud is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2010
Age: 49
Posts: 4
Gender: Male
Engine: 2007-???? 409ci (6.7L) Cummins Turbo Diesel 350hp 650lb/ft
Rep Power: 0
Rep:10
kstroud is on a distinguished road
Default Trouble code p500

I have a 2005 ram 3500 w/5.9 diesel motor. The speedo is inop and the ABS and brake light are on. This was an intermittent problem but has now become permanent. I have a trouble code p500 speed sensor A, just wondering which sensor this is refering to?
Reply With Quote
Sponsored links
  #2  
Old 02-02-2010, 05:54 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 43
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Is the P0500 the only code? You need to have the ABS module as well as the ECM scanned if you haven't already.
Reply With Quote
  #3  
Old 02-02-2010, 07:02 PM
kstroud kstroud is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2010
Age: 49
Posts: 4
Gender: Male
Engine: 2007-???? 409ci (6.7L) Cummins Turbo Diesel 350hp 650lb/ft
Rep Power: 0
Rep:10
kstroud is on a distinguished road
Default

yes, P0500 is the only code. changed both sensors (transmission and rear end) cleared code and it comes right back. What will scanning the ABS module and ECM do?
Reply With Quote
  #4  
Old 02-02-2010, 07:17 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 43
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

There might be additional codes stored. With a P0500 the wiring, ABS module or ECM is going to be at fault, not the sensors. One of the modules is seeing a speed signal but the other is not.
Reply With Quote
  #5  
Old 02-02-2010, 07:20 PM
kstroud kstroud is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2010
Age: 49
Posts: 4
Gender: Male
Engine: 2007-???? 409ci (6.7L) Cummins Turbo Diesel 350hp 650lb/ft
Rep Power: 0
Rep:10
kstroud is on a distinguished road
Default

Thanks for the info
Reply With Quote
  #6  
Old 01-09-2012, 02:14 AM
mannstripes mannstripes is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2012
Location: Los Banos, CA
Posts: 1
Gender: Male
Vehicle: 1997 Dodge Ram 1500
Color: White
Engine: 1995-1997 318ci (5.2L) Natural Gas V8 200hp 430lb/ft
Rep Power: 0
Rep:10
mannstripes is on a distinguished road
Default 1997 trouble code P0500 AND P0138

My 1997 1500 w/manual tranny is hard to start, won't hold idle and stalls. Check engine light comes on. I pulled up trouble codes with a OBDII scanner, which shows P0500 and P0138. Any help would be greatly appreciated. Thanks.
Reply With Quote
  #7  
Old 01-10-2012, 12:54 AM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

The 2 codes have nothing to do with each other.
P0500 - Speed sensor - Likely a wiring issue, but sensors have been known to fail
P0138 - O2 sensor at the rear of the catalytic convertor is likely bad. This would explain some of the running issue you explained. Don't buy the cheapest sensor out there. This is one time the OEM part is a good idea.
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #8  
Old 01-12-2012, 12:59 PM
nibroc's Avatar
nibroc nibroc is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2009
Location: the 'ville, kentucky
Posts: 7
Gender: Male
Vehicle: 89 dodge van, 92 dodge van
Trim Level: laramie
Color: light khaki metallic
Engine: 2005-???? 359ci (5.9L) Cummins ISB 610 24-Valve Diesel I6 325hp 610 lb/ft
Rep Power: 0
Rep:10
nibroc is on a distinguished road
Default

kstroud---yer problem is the sensor on the top of yer rear end--'bout $15
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:56 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum