DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-10-2012, 04:46 PM
camoman214 camoman214 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2011
Posts: 217
Gender: Male
Vehicle: None right now
Rep Power: 0
Rep:11
camoman214 is on a distinguished road
Default High Engine Idle

1999 Ram, 5.9L, auto, 4x4

I just replaced the IAC valve on my truck 'cause it wouldn't idle and figured the IAC was bad. Now the truck idles at 1800 rpm and I can't get it to idle down to normal. I did the proper IAC adjustment which calls for driving at 40 mph to allow ECM to learn the setting. I unhooked the battery for a few days hoping it would reset the ECM, that didn't work. I took the NEW IAC back to the parts store and exchanged it for another one, still idles at 1800. What else should I check? I didn't see any vacuum leaks.

Thanks for your help.
__________________

Reply With Quote
Sponsored links
  #2  
Old 01-12-2012, 03:05 PM
Stein's Avatar
Stein Stein is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2011
Location: Burlington KY
Age: 36
Posts: 22
Gender: Male
Vehicle: 1999 Dodge Ram 1500 4x4
Trim Level: SLT Laramie
Color: Black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
Stein is on a distinguished road
Default

try the (TPS) throttle position sensor I had some some idle isues on my 99 5.9 4x4. you can test them with a meter I don't have one so I just replaced the IAC and the tps and that fixed it. the iac came out in 2 pieces so I know that part was bad not sure on the tps. but the tps was 33 dollars and I replaced both within a 1/2 hr. and only spent about 70 for both. I use my Haynes for almost everything. but you can set up a free account at autozone and they have alot of helpful info on there as part local,diagrams,how to test, and what type of symtoms a failing part can cause
Reply With Quote
  #3  
Old 01-12-2012, 04:41 PM
camoman214 camoman214 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2011
Posts: 217
Gender: Male
Vehicle: None right now
Rep Power: 0
Rep:11
camoman214 is on a distinguished road
Default

I had figured the next thing I would try would be the TPS. I got one from Advance Auto Parts for under $30, so I'll slap that in and see how she reacts. Sometimes these trial and error steps can start costing a pretty good amount of money.

I'm gonna be putting it up for sale soon and it needs to be idling okay first. lol
__________________

Reply With Quote
  #4  
Old 01-13-2012, 12:44 AM
camoman214 camoman214 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2011
Posts: 217
Gender: Male
Vehicle: None right now
Rep Power: 0
Rep:11
camoman214 is on a distinguished road
Default

Stein - you hit it right on the head. Replaced the TPS and now it runs like new again.

Thanks for the quick and only reply.
__________________

Reply With Quote
  #5  
Old 01-13-2012, 09:18 AM
Stein's Avatar
Stein Stein is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2011
Location: Burlington KY
Age: 36
Posts: 22
Gender: Male
Vehicle: 1999 Dodge Ram 1500 4x4
Trim Level: SLT Laramie
Color: Black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
Stein is on a distinguished road
Default

your welcome, I'm no mechanic and I hate the trial and air thing to. mine didn't throw an engine code for either sensor. I have a cheap scanner witch has helped alot exept for that, but I knew I had to be somewhere in the ballpark. and without the code pretty much everywhere around here wanted $70-90 just to look at it, I've never had any sensors replaced on it and with 102,000 miles I figured what have I got to lose. so glad I was able to help, this forum is great I've saved alot of money reading stuff on here. the only thing I have paid to have done are my front axle shaft seals, mainly because it's winter and she wont fit in my garage, or I would have tried them to.
Reply With Quote
  #6  
Old 01-13-2012, 11:20 PM
camoman214 camoman214 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2011
Posts: 217
Gender: Male
Vehicle: None right now
Rep Power: 0
Rep:11
camoman214 is on a distinguished road
Default

Well I guess I spoke too soon. After replacing the TPS sensor and driving the truck last night, the truck ran fine and idled normal. Today, I started it up and now it's idling high again, just as it was before.
__________________

Reply With Quote
  #7  
Old 01-14-2012, 01:18 PM
Stein's Avatar
Stein Stein is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2011
Location: Burlington KY
Age: 36
Posts: 22
Gender: Male
Vehicle: 1999 Dodge Ram 1500 4x4
Trim Level: SLT Laramie
Color: Black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
Stein is on a distinguished road
Default

that sucks, did you reset again after you put in new tps
Reply With Quote
  #8  
Old 01-16-2012, 02:32 AM
camoman214 camoman214 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2011
Posts: 217
Gender: Male
Vehicle: None right now
Rep Power: 0
Rep:11
camoman214 is on a distinguished road
Default

I unhooked the battery again today for 12 hours to reset the ECM after the new TPS was installed. Still idles high between 1100 and 1600. Any other possibilities?
__________________

Reply With Quote
  #9  
Old 01-28-2012, 05:51 PM
evilsack's Avatar
evilsack evilsack is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2012
Location: Edmonton,Alberta, Canada
Age: 27
Posts: 1
Gender: Male
Vehicle: 1994 Ram 2500 5.9L 360 4x4
Trim Level: SLT Laramie
Color: Red
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
evilsack is on a distinguished road
Default re

I had the same issue going on and found that my throttle cable itself was frayed and got caughtup which made it not release completely (resulting in higher idle).

I actually resolved this issue after nearly killing myself when it stayed full throttle and wouldnt free up, i nearly went through someone house.
Reply With Quote
  #10  
Old 01-31-2012, 01:57 AM
Donmega884's Avatar
Donmega884 Donmega884 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2012
Location: Romeo, MI
Age: 30
Posts: 14
Gender: Male
Vehicle: 1998 Dodge Ram 1500 5.9 4X2
Color: Red
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
Donmega884 is on a distinguished road
Default

Have you ever tried taking out the throttle body off the manifold and making sure you clean the entire part with carb cleaner? I know it's a very cheap way too find the problem first. Also you can clean an IAC and make sure the tip is completely free of carb. Always remember to try and find the exact problem first, never throw money at and engine and hope for the best.

Sean
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 05:47 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum