2008 Ram A/C Problem - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 1ST Generation Dodge Ram 1993 & Older Dodge Ram Trucks > Heating & Cooling

Dodge Dakota Dodge Durango Dodge Nitro Jeep
Diesel Forums!
Dodge Dakota Forum Dodge Durango Forum Dodge Nitro Forum Jeep Forum
Dodge Challenger Dodge Charger Chrysler 300 Dodge Magnum
Dodge Caliber
Dodge Challenger Forum Dodge Charger Forum Chrysler 300 Forum Dodge Magnum Forum


Notices

Heating & Cooling 1st Gen Dodge Ram Heating & Cooling Problems and Questions.


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Place your Ad Here!

Reply
 
Thread Tools
  #1  
Old 10-02-2012, 11:25 PM
javelina59's Avatar
javelina59 javelina59 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Location: TEXAS
Age: 29
Posts: 25
Gender: Male
Vehicle: 2008 Dodge 1500 Hemi Mega Cab
Trim Level: SXT
Color: White
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:20
javelina59 is on a distinguished road
Default 2008 Ram A/C Problem

When starting my truck the a/c blows hard but not cool. Drive for 15 mins still hard but a little cool. I have checked tha fan it runs. Check the lines they are cold. Checked the fuses and they are not blown. I also have no weird noises comming from the condensor. What could it be? Any suggestions?

-Javelina-
__________________
Home Made CAI, Single Chambered and Dumped, 2" Leveling Kit HBS, 295/70R17 Nitto Trail Grappler M/T
Reply With Quote
Sponsored links
  #2  
Old 10-04-2012, 02:46 PM
RamTech's Avatar
RamTech RamTech is offline
Resident Technician



 
Join Date: Nov 2009
Location: Tennessee
Age: 46
Posts: 14,202
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Rep Power: 18
Rep:1915
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Low refrigerant charge is my first guess. A blend door or A/C control head problem could also be to blame.
Reply With Quote
  #3  
Old 10-04-2012, 04:11 PM
javelina59's Avatar
javelina59 javelina59 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Location: TEXAS
Age: 29
Posts: 25
Gender: Male
Vehicle: 2008 Dodge 1500 Hemi Mega Cab
Trim Level: SXT
Color: White
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:20
javelina59 is on a distinguished road
Default

i just checked the charge the refrigerant was low. thanks man, reps to you.
__________________
Home Made CAI, Single Chambered and Dumped, 2" Leveling Kit HBS, 295/70R17 Nitto Trail Grappler M/T
Reply With Quote
Reply

Bookmarks

Tags
a/c problems

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement








All times are GMT -4. The time now is 02:59 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors