DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 1ST Generation Dodge Ram 1993 & Older Dodge Ram Trucks > Powertrain > Cummins Diesel Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-28-2012, 01:44 PM
powerage powerage is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2012
Location: Canada
Posts: 3
Gender: Male
Vehicle: 1992 Cummins 2wd
Engine: 1989-1993 360ci (5.9L) Cummins diesel I6 160hp 400lb/ft
Rep Power: 0
Rep:10
powerage is on a distinguished road
Default 92 Cummins wont turn over

Just wondering if anyone can give me some advice for my truck...I wasnt here but the wife said she started the truck to let it warm up and when she came out it wasnt running, you turn the key and the pre heat lights dont come on, lots of power in the battery and frome what I have read on here I doubt its the ignition switch. I cleaned all battery connections etc, and all the fusible links that I have found are ok. I dont know much about Dodge wiring stuff, and less about diesels lol! If it was a carburated small block chevy I would be ok! Its an automatic so the neutral saftey switch could come into play,I did move the shift lever to all positions and tried it no go. I am sure its nothing serious although the stopping running does have me concerned,any help ,suggestions or wiring diagrams greatly appreciated!!
Reply With Quote
Sponsored links
  #2  
Old 02-02-2012, 06:29 PM
darcylee79 darcylee79 is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2011
Location: New Brunswick
Posts: 17
Gender: Male
Vehicle: 1987 Dodge Power Ram
Trim Level: Power Ram
Color: Green
Engine: 1981-1987 318ci (5.2L) LA V8 140hp
Rep Power: 0
Rep:10
darcylee79 is on a distinguished road
Default

Try looking at the starter wiring. Not sure on the dodge trucks but about every vehicle has power going from your battery to the starter, then goes from there. Sounds like your main battery wire may have rotted off or lost connection. Make sure it is all clean and the ends are securely on the wire. I have seen the end still be on the wire and be corroded off on the inside, the wire end will pull right out. Also check your grounds. If no lights or anything on it sounds like the starter wiring. Try there and let us know what you find out and go from there.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:45 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum