DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical


Electrical 4th Gen Dodge Ram Electrical Problems and Questions.

Latest Vendor News
Addictive Desert Designs!
Bayou Goat Mounts

Thread Tools
Old 02-27-2012, 08:59 PM
trojanman22 trojanman22 is offline
Dodge Ram Forum Senior Member
Join Date: Feb 2012
Location: Haltom City TX
Age: 28
Posts: 295
Gender: Male
Vehicle: 2010 Ram 2500 Laramie Megacab
Trim Level: Laramie
Color: Black
Engine: 2010-2012 409ci (6.7L) Cummins Turbo Diesel 305hp 610lb/ft (Chassis Cab)
Rep Power: 0
trojanman22 is on a distinguished road
Default flashing LED issue

I just got the map lights and dome lights I ordered from i installed the lights and they look great, however when I pressed the map light to turn it on it flashes....then i pushed the other map did the same thing....and then the dome light......again same thing. WTF?? I took one of the map lights out and rotated it 180 degrees and it still does the same thing. they work fine though when i unlock my truck and open the door or just click the dome light wheel over to turn them on..but when i want to manually turn them on they start flashing about every half second. but its not a fast flas like a strobe.
Reply With Quote
Sponsored links


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:38 PM.

= Copyright a Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.