DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 3.7L PowerTech V6 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-08-2012, 09:22 AM
j.arnold.29714 j.arnold.29714 is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2012
Location: Charleston, SC
Age: 30
Posts: 2
Gender: Male
Vehicle: 2006 Dodge Ram
Color: Red
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 0
Rep:10
j.arnold.29714 is on a distinguished road
Default Won't crank

Hey guys, I've got an 06 Ram 1500 2WD 3.7L. Crappy on gas mileage but I love the truck. I've got an issue though, it won't crank.

When I put the key in the ignition the lights, radio, etc will come on. But nothing when I turn the key to crank. Put the truck in neutral, still won't crank. The battery has 13.5V, and also voltage is going down to the starter as well. The posts and terminals on the battery have been cleaned and put back on, still won't crank. Temporarily, I've got in hot-wired right now to get it started but it takes two people.

I hooked up the computer dashboard diagnostic reader and there were no errors. I'm thinking maybe a sensor has been knocked loose, but the sensor, whichever one it may be, isn't loose enough to throw up an error? Or am I dealing with a Neutral Safety Switch issue?

Last question, can the oil pressure switch, if clogged, keep the engine from cranking? Wouldn't that have put an error code into the dashboard computer?

Thanks guys, love this forum.
Reply With Quote
Sponsored links
  #2  
Old 03-08-2012, 08:16 AM
mattgindy500 mattgindy500 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: Stafford,New York
Age: 31
Posts: 5
Gender: Male
Vehicle: 2007 dodge ram 1500 ST 2WD
Trim Level: ST
Color: red
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 0
Rep:10
mattgindy500 is on a distinguished road
Default

good luck, i just had my engine temp sensor replaced becuase it would not let me truck start. the sensor kept making the truck think it was over heated and would not alow it to start. by the way what is bad MGP to you? i get 16.5 for the norm. i would like to get at least 17.5 as guys i work with that have V8s of any make chevy ford dodge all get 17+MPG good luck getting your rig back on the road.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 03:51 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum