DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > Dodge Ram Detailing and General Maintenance Forum > Oil Change


Notices

Oil Change Ready to change the oil in your Dodge Ram? Engine -Trans - Differential - Transfer Case


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #21  
Old 04-18-2012, 02:10 PM
bigbadwillie's Avatar
bigbadwillie bigbadwillie is offline
Dodge Ram Forum Member
 
Join Date: Apr 2011
Location: Winnipeg,Mb,Canada
Age: 31
Posts: 54
Gender: Male
Vehicle: 2011 Ram Sport
Trim Level: Sport Quad Cab
Color: Deep Cherry
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
bigbadwillie is on a distinguished road
Default

Same crap happened to my 2011 Hemi, service guy said they loosing off over time. I laughed and couldnt believe it. think the kid that installed it last was limp wristed
Reply With Quote
Sponsored links
  #22  
Old 04-20-2012, 10:19 AM
RamManCan RamManCan is offline
Dodge Ram Forum Member
 
Join Date: Jan 2012
Location: Ontario Canada
Age: 31
Posts: 64
Gender: Male
Vehicle: 2010 Ram
Trim Level: Sport
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
RamManCan is on a distinguished road
Default

Over torquing can cause problems too. I wouldn't accept it as "that's the way they are". I do all my own oil changes and the only problem I had was using Fram filters. They caused the engine to have a bad tick on cold start ups more often than the Mopar ones. When I looked into it, it seems that the check valve in the Fram filter is weaker, and lets the oil drain back. I guess you get what you pay for.
Reply With Quote
  #23  
Old 04-20-2012, 11:02 AM
brokenwrench66's Avatar
brokenwrench66 brokenwrench66 is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2011
Location: Ottawa, ON, Canada
Age: 48
Posts: 281
Gender: Male
Vehicle: 2009 1500 SLT 4X4
Color: Stone White
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 4
Rep:81
brokenwrench66 will become famous soon enough
Default

Quote:
Originally Posted by bigbadwillie View Post
...service guy said they loosing off over time.
That's hilarious! Mine seem to do the opposite, I put them on hand tight and then have to wrench the hell out of them to get them off!
__________________
Dual Exhaust, K&N drop in, TFP chrome mirror covers, TFP stainless steel door handle covers, molded splash guards, Leer cap
Reply With Quote
  #24  
Old 04-23-2012, 08:51 PM
05Train's Avatar
05Train 05Train is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2010
Location: Maryland
Posts: 75
Gender: Male
Vehicle: 2010 Ram
Trim Level: Sport Quad Cab
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:24
05Train is on a distinguished road
Default

Yep, had one of the seams come apart on the filter and dump oil everywhere.
Reply With Quote
  #25  
Old 05-12-2012, 12:32 AM
dawg11's Avatar
dawg11 dawg11 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2012
Location: Oregon
Posts: 115
Gender: Male
Vehicle: 2010 Hemi Ram 1500 Crewcab 4x4
Trim Level: SLT
Color: Brilliant Black with Pearl Coat
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
dawg11 is on a distinguished road
Default

Just had this problem with my '10 after a dealer oil change . took it back and told them it was leaking from the filter , and they put on a new filter and topped off the oil . When I asked how they were gonna get the oil off the bottom my truck , he sent two techs with rags and degreaser to wipe everything down . Maybe that will get them to slow down and double check things , somehow I doubt it .
__________________
Pro Comp leveling kit , Locking billet fuel door , Cabin air filter , Spay in Bedliner , 180* stat , Catch can , Tailgate assist , U-Connect Phone , K&N 63 Series C.A.I. . Flowmaster Super 44 . Dual Exhaust . Eaton TruTrac LSD
Reply With Quote
  #26  
Old 05-22-2012, 06:35 AM
Daddy454 Daddy454 is offline
Dodge Ram Forum Junior Member
 
Join Date: Feb 2010
Location: Nevada
Posts: 31
Gender: Male
Vehicle: 2010 Ram 1500 SLT 4x4
Color: Inferno Red
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Daddy454 is on a distinguished road
Default

I did have something similar happen to mine.Took it in for an alignment,and the dealer sent it to a Big-O cuz their machine was down.They tried to say my rack & pinion was shot-@13k!Went back to the dealer and they said my filter was just loose.I do all my own oil changes,and it may have just worked a little loose- my bad.Haven't had problem since.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 04:50 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum