DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #11  
Old 04-23-2012, 01:19 PM
Ramathorne Ramathorne is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Location: Canada
Age: 28
Posts: 662
Gender: Male
Vehicle: 2010 Dodge Ram 1500 Quad Cab
Trim Level: Sport
Color: Deep Water Blue Pearl
Rep Power: 0
Rep:48
Ramathorne is on a distinguished road
Default

Quote:
Originally Posted by brad12kx View Post
Are you sure it's a TIPM issue? I have seen cases where the connector on the bottom of the TIPM lost contact. Removing it and reconnecting can sometimes restore operation. On yours it is connector 'C'. The fog lights are on pins 23 (left - white/yellow) & 24 (right - white/orange).
I am just going by what I was told at the dealer as I do not know a lot about this...What am I looking for?...Any pics etc of where this is?...I would like to try you suggestion before doing the switch thing...
__________________

Reply With Quote
Sponsored links
  #12  
Old 04-23-2012, 02:44 PM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

My thread on installing the tailgate lock includes pictures, etc. on removing the TIPM. There is a link to it in my signature.

If you tackle this, I will recommend that you remove and reconnect all 7 connectors on the bottom of the TIPM. That way you have cycled all the contacts for all the circuits. Even if your fog light issue turns out to be a TIPM failure, cycling these connections is good preventative maintenance.

*** EDIT *** I just realized the thread references to the Mopar install document. << Link
TIPM removal is on page 8.
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI

Last edited by brad12kx; 04-23-2012 at 03:05 PM.
Reply With Quote
  #13  
Old 04-23-2012, 08:14 PM
TurboCup87 TurboCup87 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2012
Location: WV
Posts: 233
Gender: Male
Vehicle: 2012 1500 Sport Crew 4x4
Trim Level: Sport
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:28
TurboCup87 is on a distinguished road
Default

My truck is 3 weeks old. Fogs have never worked, but the IP fog indicator does come on. There are bulbs present and the connectors are on. Dealer is 25' away, so I can't just drop by after work. Also two trips are guaranteed. Suspect that the problem is something like this. Just installed my tailgate remote lock last weekend. They better not give me grief about that.
Reply With Quote
  #14  
Old 04-24-2012, 09:26 AM
Pyroboy5000's Avatar
Pyroboy5000 Pyroboy5000 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2012
Location: GA
Posts: 444
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: Laramie SLT
Color: Intense Blue Pearl
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:37
Pyroboy5000 is on a distinguished road
Default

wow. that sucks. but since it is so new i would highly reccomend taking it back under warranty so you dont accidentaly void it in trying to fix it yourself.

if they dont fix it get mad and demand them to. that is their fault and its their responsibility to fix it.
__________________
randomness rules!
Reply With Quote
  #15  
Old 05-04-2012, 01:20 PM
Ramathorne Ramathorne is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Location: Canada
Age: 28
Posts: 662
Gender: Male
Vehicle: 2010 Dodge Ram 1500 Quad Cab
Trim Level: Sport
Color: Deep Water Blue Pearl
Rep Power: 0
Rep:48
Ramathorne is on a distinguished road
Default

Quote:
Originally Posted by brad12kx View Post
My thread on installing the tailgate lock includes pictures, etc. on removing the TIPM. There is a link to it in my signature.

If you tackle this, I will recommend that you remove and reconnect all 7 connectors on the bottom of the TIPM. That way you have cycled all the contacts for all the circuits. Even if your fog light issue turns out to be a TIPM failure, cycling these connections is good preventative maintenance.

*** EDIT *** I just realized the thread references to the Mopar install document. << Link
TIPM removal is on page 8.
Going out to try this now
__________________

Reply With Quote
  #16  
Old 05-04-2012, 01:26 PM
APSTRAM's Avatar
APSTRAM APSTRAM is offline
Dodge Ram Forum Member
 
Join Date: Oct 2010
Location: Wisconsin
Age: 48
Posts: 1,342
Gender: Male
Vehicle: 2012 Ram 2500 Crew Cab 4x4
Trim Level: Big Horn
Color: Deep Cherry Red
Engine: 2010-20?? 345ci (5.7L) Hemi V8 383hp 400lb/ft (2500/3500)
Rep Power: 4
Rep:82
APSTRAM will become famous soon enough
Default

Since there is a sales code involved maybe the programming has been wiped and needs to be reflashed. Has the dealer reflashed your vehicle recently?
Reply With Quote
  #17  
Old 05-04-2012, 02:13 PM
Ramathorne Ramathorne is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Location: Canada
Age: 28
Posts: 662
Gender: Male
Vehicle: 2010 Dodge Ram 1500 Quad Cab
Trim Level: Sport
Color: Deep Water Blue Pearl
Rep Power: 0
Rep:48
Ramathorne is on a distinguished road
Default

Well, I tried that...And now...I have no fog lights LOL
Both are not working now instead of just the one... (I did it twice to make sure everything was back in place)
I wonder if TIPM issues are covered under the powertrain warranty that is on my truck until 100,000km?
Likely not!
__________________

Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:00 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum