DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2012 Dodge Ram Forum


Notices

2012 Dodge Ram Forum For specific discussion of the 2012 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 05-16-2012, 12:12 PM
staypuff staypuff is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2012
Location: Walker Louisiana
Posts: 17
Gender: Male
Vehicle: 2012
Trim Level: Bighorn
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
staypuff is on a distinguished road
Default Strange cai issue

I have the K&N 63 series CAI and when I go WOT it feels like the truck is bogging some and I get a stinky smell. Only other MOD is removed the stock y-pipe and replaced with true dual into DI/DO magnaflow.


I reinstalled the factory intake system and the issue goes away.
I was thinking the ECU is registering more air movement than exspected and torque manamgement is kicking in. If i only go say 3/4 throttle the truck goes like a bat out of hell.

Anyone else have this issue?
Reply With Quote
Sponsored links
  #2  
Old 05-16-2012, 12:41 PM
CanDan's Avatar
CanDan CanDan is offline
Dodge Ram Forum Member
 
Join Date: Apr 2012
Location: Barrie - CANADA
Posts: 63
Gender: Male
Vehicle: 2012 1500
Trim Level: Sport
Color: 1500
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:23
CanDan is on a distinguished road
Default

Possible things to look at:
1: Reset your ECU - Disconnect your battery for 10minutes
2. Damp filter - Did you clean your filter or oil it too much before install?
3. Dirty or damaged MAF
4. MAF installed backwards (Not sure about the RAM but this does matter on some cars)

I would check these things first. Changing a intake should not be causing this.

Can you explain the smell? Any smoke, what colour?


*note, I am still waiting for delivery on my RAM and thus have to experience on the truck. I am just looking at possible simple causes that are pretty generic to most engines.
Reply With Quote
  #3  
Old 05-16-2012, 12:43 PM
CanDan's Avatar
CanDan CanDan is offline
Dodge Ram Forum Member
 
Join Date: Apr 2012
Location: Barrie - CANADA
Posts: 63
Gender: Male
Vehicle: 2012 1500
Trim Level: Sport
Color: 1500
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:23
CanDan is on a distinguished road
Default

*Edit: Check your vacuum hoses. This reminds me of a vacuum leak problem now that I think of it.
Reply With Quote
  #4  
Old 05-16-2012, 02:28 PM
staypuff staypuff is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2012
Location: Walker Louisiana
Posts: 17
Gender: Male
Vehicle: 2012
Trim Level: Bighorn
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
staypuff is on a distinguished road
Default

it's kind of a sulfer smell.

i don't have a MAF sensor or none that I can see. All I have is a little IAT sensor in the intake tube.

The filter is brand new out the box. it wasn't dripping with oil or anything when I installed it.

I haven't tried reseting the ECU yet.

pcv hose setup looks fine. Maybe i'll inspect it for cracks
Reply With Quote
  #5  
Old 05-16-2012, 02:41 PM
HemiSwagg's Avatar
HemiSwagg HemiSwagg is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2011
Location: West Texas
Posts: 86
Gender: Male
Vehicle: 2012 Ram 1500 Express RC
Trim Level: Express
Color: Mineral Gray Metallic
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
HemiSwagg is on a distinguished road
Default

Strange...I have a burnt sulfery type smell as well on mine but only at WOT. All I have is a K&N panel filter and a magna flow y pipe to a cherry bomb mufler.

Staypuff - Question...at WOT from 1st to 2nd is there any type of hessitation in the shifting and does exhaust make a strange sort of pop sound? Mine does and thats when I get the smell. Maybe the ECU is not adjusting to the increased air flow some how and is not burning the gas properly...
__________________
K&N Panel Filter, Magnaflow Ypipe, Cherry Bomb Muffler, In-cabin air filter mod, 3.92 with LSD, Fastman Standard MOD TB.
Reply With Quote
  #6  
Old 05-16-2012, 06:24 PM
staypuff staypuff is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2012
Location: Walker Louisiana
Posts: 17
Gender: Male
Vehicle: 2012
Trim Level: Bighorn
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
staypuff is on a distinguished road
Default

1st and 2nd seem to be fine from a stop. It's more noticable when I'm already moving and kick it in to pass someone. I tried swaping the stock air box setup back in and it fixes it. I think it's tune related. I'm gonna put the stock setup back in till they come out with a tuner. after a tuner comes out i'm going with LT's, ORX pipe and a cam as well
Reply With Quote
  #7  
Old 05-17-2012, 03:43 PM
HemiSwagg's Avatar
HemiSwagg HemiSwagg is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2011
Location: West Texas
Posts: 86
Gender: Male
Vehicle: 2012 Ram 1500 Express RC
Trim Level: Express
Color: Mineral Gray Metallic
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
HemiSwagg is on a distinguished road
Default

staypuff - yeap mine does it when passing as well. Quite annoying.

Ahh yess...longtubes with x pipe to true duals would be sick. Throw in a cam and a tune (whenever that happens) with the intake and possibly a fastman TB...you'd be in good shape. I called Hennesey Performance and they said American Racing Headers makes adapters for the 2011-2012 5.7's. Regardless, without a tune it would be a waste.

So, your going back to stock? As in putting the stock exhaust back on as well as intake? It would be interesting to see if you feel a difference. Have you gone to the track? What did you do before and after the intake and exhaust mods?
__________________
K&N Panel Filter, Magnaflow Ypipe, Cherry Bomb Muffler, In-cabin air filter mod, 3.92 with LSD, Fastman Standard MOD TB.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:29 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum