DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Suspension


Notices

Suspension 3rd Gen Dodge Ram Suspension Problems and Questions


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 05-18-2012, 01:21 AM
James2k10 James2k10 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2012
Location: Fort Mcmurray, Alberta
Age: 32
Posts: 3
Gender: Male
Vehicle: 2005 Dodge Ram 2500
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
James2k10 is on a distinguished road
Default Need help. Noise in front suspension at road speed.

Well firstly I have a 2005 dodge ram 2500 with the hemi. Bought the truck with an 8" lift and 35" tires. I needed a new set of tires so I decided to upgrade while I was at it so now I'm sitting on 38" tires which caused a little rubbing on the flare at full crank. I installed a set of sulastic shocks in the rear which raised it another inch while making the ride a hell of a lot nicer lol and installed an 1.5" coil spring spacer on the front to eliminate the rubbing but now I have a weird rubbing/grinding metal sound when at speed on the highway. I was thinking that maybe the front driveshaft might be at too much of an angle now but any advice or suggestions would be much appriciated. Thanks, James.
Reply With Quote
Sponsored links
  #2  
Old 05-30-2012, 02:51 PM
Lawndart's Avatar
Lawndart Lawndart is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2011
Location: Tucson
Age: 43
Posts: 9
Gender: Male
Vehicle: 2011 Ram 3500
Trim Level: Longhorn
Color: Rugged Brown
Engine: 2007-2011 409ci (6.7L) Cummins Turbo Diesel 350hp 650lb/ft
Rep Power: 0
Rep:10
Lawndart is on a distinguished road
Default

I have the same noise starting at 35 MPH after getting a 6" Top Gun lift put on yesterday. It is a pretty loud tapping sound that goes away with 4HI on. I can't seem to find any help on the subject yet. Tomorrow the mechanic is going to remove the front drive shaft and drive it to see if the noise is eliminated but we still don't have a fix it that is it. Any ideas from anyone?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:45 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum