DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2011 Dodge Ram Forum


Notices

2011 Dodge Ram Forum For specific discussion of the 2011 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 06-05-2012, 11:18 AM
fatback99 fatback99 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2011
Location: St Louis Missouri
Posts: 24
Gender: Male
Vehicle: 2011 Ram 1500
Trim Level: Sport
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
fatback99 is on a distinguished road
Default 2011 Radio Issues

Hello,

I'm looking at buying a used 2011 laramie with NAV and backup camera. Is anybody having any issues with these?

Reason I ask is my mom's town&country radio locks up after about 20 minutes of driving then it resets itself. She hasn't taken it in yet, but I'm sure the head unit is $1500 if you are out of warranty.
Reply With Quote
Sponsored links
  #2  
Old 06-05-2012, 02:02 PM
Jayincali's Avatar
Jayincali Jayincali is offline
Dodge Ram Forum Member
 
Join Date: Jan 2012
Location: So Cal, I.E.
Posts: 505
Gender: Male
Vehicle: 2014 Dodge Ram 8 Speed 3.92
Trim Level: Sport
Color: Deep Cherry Red Crystal Peral
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:95
Jayincali will become famous soon enough
Default

I don't have a laramie, but do have a loaded Big Horn with zero issues with radio, nav, or camera.
Reply With Quote
  #3  
Old 06-05-2012, 02:12 PM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 17,866
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 18
Rep:2583
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

I have heard of only a few issues with the Gen 4 radios, Nav systems & back up cameras
my own system works great

most of the complaints are for the the Smart Phone use with them & that part is being corrected, software & firmware issues
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
  #4  
Old 06-05-2012, 10:56 PM
dvdsram dvdsram is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2011
Location: tulsa, ok
Age: 63
Posts: 16
Gender: Male
Vehicle: 2011 dodge ram Laramie
Trim Level: Laramie QC
Color: blue
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
dvdsram is on a distinguished road
Default

I have a 2011 Laramie with the nav back up camera etc and ther only trouble I had was the wireless module for the uconnect had to be replaced but has been working fine ever since
Reply With Quote
  #5  
Old 06-20-2012, 07:56 PM
Grumpy Gus Grumpy Gus is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2012
Location: New Mexico
Age: 30
Posts: 1
Gender: Male
Vehicle: 2011 Ram 1500 4.7
Trim Level: Slt
Color: Black
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:10
Grumpy Gus is on a distinguished road
Default

Have a 1500 slt 4x4 and only in the past couple weeks I get in and the radio turns on but the screen is off and I have no control over volume, station or power after my 20 min drive home it usually works like normal again. Thats my only complaint.
Reply With Quote
  #6  
Old 06-22-2012, 05:05 PM
semlohde semlohde is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2011
Location: Southaven, MS
Posts: 188
Gender: Male
Vehicle: 2014 RAM Laramie LongHorn Mega
Trim Level: LaramieLongHorn Mega
Color: bright white
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
semlohde is on a distinguished road
Default

I have a 2011 1500 Outdoorsman. Bluetooth with iPhone4 fast and choppy. I have to press the power(lock) button on the iPhone to make it work. I also just battled with my dealer and dodge about the backup camera being dark. This is the 430n RHB. They replaced the camera - no change, and said they check other cameras on the lot- the same darkness. Dodge said I could upgrade at my cost. I have a 2011 2500 with the 730n rer and the camera is perfect. The 730n also has a cd to update for the iPhone and it streams fine. For me, the 430n RHB is expensive junk and I wouldn't get it!! The radio and gps(Garmin) are fine and adjust brightness fine. But that camera is all but worthless in bright sunlight and just fair with clouds or night. Ed
Reply With Quote
  #7  
Old 06-22-2012, 05:17 PM
drew7811's Avatar
drew7811 drew7811 is offline
Dodge Ram Forum Member
 
Join Date: Mar 2012
Location: Walton, Ky
Age: 35
Posts: 70
Gender: Male
Vehicle: 2011 Dodge Ram Laramie Crew
Trim Level: Laramie
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
drew7811 is on a distinguished road
Default

Quote:
Originally Posted by dvdsram View Post
I have a 2011 Laramie with the nav back up camera etc and ther only trouble I had was the wireless module for the uconnect had to be replaced but has been working fine ever since

Just curious but what was the problem with the wireless module? I have been noticing some issues with my uconnect and my phone a bunch lately. I also have an '11 Laramie. Was it a warranty fix or out of pocket? If so how bad was the damage?
Reply With Quote
  #8  
Old 06-23-2012, 12:36 PM
xsdbs xsdbs is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2011
Location: Over Here, Hi
Age: 53
Posts: 797
Gender: Male
Vehicle: green flying carpet
Trim Level: upper and lower
Rep Power: 0
Rep:73
xsdbs will become famous soon enough
Default

2 things here if I may butt in:
1) I think that the replacing of the camera was a bad diagnostic step in your repair. What is the SW version of the radio? I believe that you may have an older SW version and if I remeber correctly, there is an update for the camera issue. i can look into this on Monday, but please get me your current SW version. It'll be in the set up menu.
2) For the iPhone streaming fast, I will bet that you haven't had the Uconnect sw update performed on it. There has been a TSB out on it since June 29th 2011. Many members here have applied it themselves with the file and instructions that I have provided on this forum. This will take care of that issue and takes about 20 minutes to perform.

I am sure that you know the 730N is not without its issues also. It has several of its own.






Quote:
Originally Posted by semlohde View Post
I have a 2011 1500 Outdoorsman. Bluetooth with iPhone4 fast and choppy. I have to press the power(lock) button on the iPhone to make it work. I also just battled with my dealer and dodge about the backup camera being dark. This is the 430n RHB. They replaced the camera - no change, and said they check other cameras on the lot- the same darkness. Dodge said I could upgrade at my cost. I have a 2011 2500 with the 730n rer and the camera is perfect. The 730n also has a cd to update for the iPhone and it streams fine. For me, the 430n RHB is expensive junk and I wouldn't get it!! The radio and gps(Garmin) are fine and adjust brightness fine. But that camera is all but worthless in bright sunlight and just fair with clouds or night. Ed
Reply With Quote
  #9  
Old 06-23-2012, 12:42 PM
xsdbs xsdbs is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2011
Location: Over Here, Hi
Age: 53
Posts: 797
Gender: Male
Vehicle: green flying carpet
Trim Level: upper and lower
Rep Power: 0
Rep:73
xsdbs will become famous soon enough
Default

1) There is a TSB # 08-019-12 that is available for the 2011 vehicles, it is a revised edition of the TSB from last year, # 08-036-11 rev A.
2) what phone do you have?
3) what are te issues that you're having?
4) Have you tried rebooting your phone? I have seen sevral issues that have "just started" to happen an a simple reboot of the phone helps a lot. I have an iPhone 4S (had a 4 prior to the 4S) and have to reboot them a few times a month for various issues other than just Bluetooth issues. Phones are nothing more than a mini computer and how often do you have to reboot your computer?
5) Have you performed a phone update lately? Did you notice the issues after the update? I have seen new updates affect a phone and Uconnect also.



Quote:
Originally Posted by drew7811 View Post
Just curious but what was the problem with the wireless module? I have been noticing some issues with my uconnect and my phone a bunch lately. I also have an '11 Laramie. Was it a warranty fix or out of pocket? If so how bad was the damage?
Reply With Quote
  #10  
Old 06-26-2012, 11:27 AM
semlohde semlohde is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2011
Location: Southaven, MS
Posts: 188
Gender: Male
Vehicle: 2014 RAM Laramie LongHorn Mega
Trim Level: LaramieLongHorn Mega
Color: bright white
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
semlohde is on a distinguished road
Default

I have another thread here- RHB BACKUP CAMERA- for more details. but my phone is iphone4 with 5.1.1. dodge said they use 5.0.1. I say shouldn't matter. my truck SW app is 20.02.01. press the lock on the iPhone and it streams fine. unlock and it's fast and skips. I'm getting the galaxy s3 so will try that next week. I'll ask the service guy about this tsb 08-019-12. thanks
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:11 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum