help!!! 98 1500 gauges not working abs light on - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Performance Mods - Engine - 5.2 Liter V8


Notices

Custom Dodge Ram Performance Mods - Engine - 5.2 Liter V8 Discuss modifying your Dodge Ram with Performance Parts and Accessories!


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 06-13-2012, 04:01 PM
Dodge Boy13's Avatar
Dodge Boy13 Dodge Boy13 is offline
Dodge Ram Forum Senior Member
 
Join Date: Apr 2012
Location: Rockaway NJ
Posts: 396
Gender: Male
Vehicle: 1998 Dodge Ram 1500
Trim Level: sport
Color: Intense Blue
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:23
Dodge Boy13 is on a distinguished road
Angry help!!! 98 1500 gauges not working abs light on

so my truck hasnt been ran since last week and i got in it today to run it and all my gauges are dead and my abs and airbag lights are on an ideas?

loose connection
bad computer???
__________________
My Build Thread!!
http://www.ramforumz.com/showthread.php?t=118514
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 08-01-2012, 10:34 PM
nenningr@gmail.com nenningr@gmail.com is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2012
Location: Gulf Coast
Age: 44
Posts: 1
Gender: Male
Vehicle: 2001 Dodge Ram 1500 5.2
Trim Level: laramie
Color: garnett
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
nenningr@gmail.com is on a distinguished road
Default

Mine does this too. it has other symptoms such as power windows quit working, A/C won't come on, or the worst is it wont stay running unless i hold the gas all the way to the floor??! It only seems to happen when it hot out. It will clear up if i wiggle the ignition switch but, i don't think its the problem cause I've replaced it twice. When i try to check with code reader it says link failure so maybe short in +12v line in steering column. I'd like to know if you find what causes yours.
Reply With Quote
  #3  
Old 08-01-2012, 10:39 PM
Dodge Boy13's Avatar
Dodge Boy13 Dodge Boy13 is offline
Dodge Ram Forum Senior Member
 
Join Date: Apr 2012
Location: Rockaway NJ
Posts: 396
Gender: Male
Vehicle: 1998 Dodge Ram 1500
Trim Level: sport
Color: Intense Blue
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:23
Dodge Boy13 is on a distinguished road
Default

never actually figured it out...i just got really pissed one day and punched the dash and knock on wood it stopped acting up haha
__________________
My Build Thread!!
http://www.ramforumz.com/showthread.php?t=118514
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 01:28 AM.


Copyright © VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors