DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2011 Dodge Ram Forum


Notices

2011 Dodge Ram Forum For specific discussion of the 2011 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-11-2012, 12:38 PM
Laramie Longhorn Kid's Avatar
Laramie Longhorn Kid Laramie Longhorn Kid is offline
Dodge Ram Forum Junior Member
 
Join Date: Nov 2011
Location: Midland TX,
Age: 19
Posts: 42
Gender: Male
Vehicle: 2011 Dodge Ram
Trim Level: Laramie Longhorn
Color: Cherry Red Pearl
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Laramie Longhorn Kid is on a distinguished road
Default 2011 Dodge Ram 1500 HID Problems!

Okay so on my truck I have my HIDS set up with the CANBUS ballast and a relay. They worked great for a while until l one day they wouldn't come on. I checked the fuse on the relay and it was blown so i replaced it and that fixed the problem. A couple of days later one of the ballast gave out so i replaced it with a new one and they worked perfectly fine again. But now they won't come on again and i checked the fuse and its not blown. But one time that i did try to turn them on they just flickered and only one came on. I dont know whats wrong. All of my connections are good and im running CANBUS ballasts and a relay. Any help would be greatly appreciated. MAybe a blown fuse under the hood? Or maybe i need to get rid of the relay? Or maybe the auto lights feauture is messing it up? The HIDS in my fogs still work perfectly.
Reply With Quote
Sponsored links
  #2  
Old 07-11-2012, 10:12 PM
stricnine's Avatar
stricnine stricnine is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2011
Location: moparville
Posts: 127
Gender: Male
Vehicle: 2011 Hemi QC
Trim Level: sport
Color: silver
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:65
stricnine will become famous soon enough
Default

I just ordered the retro solutions kit and the directions specifically state to disable the auto on light feature. Give that a try.
__________________
2011 HEMI Quad Cab w/ 3.92's; K&N Aircharger; Belltech 2/4 Drop; BT Catch Can; Truxedo Lo Pro QT
Reply With Quote
Reply

Bookmarks

Tags
electrical problems, hid flickering headlights, hid problem

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:16 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum